Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm in the midst of setting up a standard web server on EC2. However, I'm just getting a 403 error on remote access, despite following tutorials (which describe a very simple process).

So far, I have

  1. Installed httpd and associating
  2. Mounted /var/www/vhosts/foo to an s3 bucket dir.
  3. Installed php
  4. Edited httpd conf adding a NameVirtualHost *:80, a

    <Directory "/var/www/vhosts/foo/*bar*">
    Satisfy Any
    Order Allow,Deny
    Allow from all
    </Directory>
    

and a

SuexecUserGroup root root

and a

<VirtualHost *:80>
  ServerName foo.mydomain.com
  ServerAlias mydomain.com
  ServerAdmin webmaster@mydomain.com
  DocumentRoot /var/www/vhosts/foo/bar/htdocs
  CustomLog /var/www/vhosts/fooh/bar/logs/access.log common
  ErrorLog /var/www/vhosts/foo/bar/logs/error.log
  SuexecUserGroup root root
  ScriptAlias /cgi-bin/ "/var/www/vhosts/foo/cgi-bin.bar/"
</VirtualHost>

Now, I'm aware root isn't great at this stage. But, until the problem is sorted I haven't gone about changing that.

I've restarted httpd - I just get 403 errors. I can see the hits on access.log on the subdomain etc. so it is getting through (via my foo.mydomain.com) - but it's not going past a 403 and I can't figure out a reason why. All the tutorials say this is mega easy.

share|improve this question

1 Answer 1

The error log should be the first point of call. What does:

  /var/www/vhosts/foo/bar/logs/error.log

Show?

share|improve this answer
    
Simply:- [Tue Oct 25 11:06:21 2011] [error] [client x.x.x.x] (13)Permission denied: access to /index.php denied –  waxical Oct 25 '11 at 12:32
    
At a guess I'd say that the wildcard isn't working correctly. Can you replace it with multiple directories? Or the parent instead? To see if that helps. –  Steve Kemp Oct 25 '11 at 12:48
    
Have now got from <Directory "/foo/bar/yes"> - no change. However, I have managed to get it working with STANDARD /var/www/html useage - i.e. a static file in there works. –  waxical Oct 25 '11 at 13:59
    
For people who are experiencing this;- it was s3fs causing the problems - not or the first time. Basically, when mounting the bucket you must use the -o flag, allowing other users to use the mounted s3 dir. Unfortunately, if you don't do this everything appears fine, you can even chown and chmod dirs within - but it'll stop apache access and other service and commands... very painful. s3fs -o allow-others /bucketname/foo/bar –  waxical Oct 25 '11 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.