Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I downloaded the newest Valgrind and extracted it.

I run

./configure --prefix=/usr/local/valgrind
make

which gives me

make: *** No targets specified and no makefile found.  Stop.

I run

make install

It gives me

make: Nothing to be done for `install'.

How can you install Valgrind to the newest OS X?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Version 3.4.1 is incompatible with Mac OS X as far as I know. As it wasn't until more recently (May 2009 - 3.4.1 was released in February 2009) that valgrind was given "compatibility." The Mac OS X port is as quoted from the Mac OS X page:

This port is UNSUPPORTED and INCOMPLETE and BUGGY

You'll need to get the latest from svn as documented on valgrind.org:

svn co svn://svn.valgrind.org/valgrind/trunk valgrind
cd valgrind
./autogen.sh
./configure --prefix=...
make
make install

You will need autoconf and automake as well that can be most easily installed using MacPorts

For debugging the "configure, make, make install" dance:

Did you see what error in the configure phase came up? You can't make (and subsequently install using make install) unless the configuration works correctly.

share|improve this answer
1  
@Chealian: Thank you for your answer! –  Masi Jun 26 '09 at 22:51

The instructions say you need to do ./autogen.sh before make.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.