Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded the newest Valgrind and extracted it.

I run

./configure --prefix=/usr/local/valgrind

which gives me

make: *** No targets specified and no makefile found.  Stop.

I run

make install

It gives me

make: Nothing to be done for `install'.

How can you install Valgrind to the newest OS X?

share|improve this question
Did you cd into the newly created directory? You have to be in the directory after you extract it to run those commands. – user43633 Jul 7 '15 at 0:54
up vote 3 down vote accepted

Version 3.4.1 is incompatible with Mac OS X as far as I know. As it wasn't until more recently (May 2009 - 3.4.1 was released in February 2009) that valgrind was given "compatibility." The Mac OS X port is as quoted from the Mac OS X page:


You'll need to get the latest from svn as documented on

svn co svn:// valgrind
cd valgrind
./configure --prefix=...
make install

You will need autoconf and automake as well that can be most easily installed using MacPorts

For debugging the "configure, make, make install" dance:

Did you see what error in the configure phase came up? You can't make (and subsequently install using make install) unless the configuration works correctly.

share|improve this answer
@Chealian: Thank you for your answer! – Masi Jun 26 '09 at 22:51

The instructions say you need to do ./ before make.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.