Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently created by first EC2 server using an Ubuntu 11.10 AMI (previously had been using 10.4). The default terminal behavior for this server seems a bit odd.

When I ssh to the server from a Mac terminal window, and then ssh to the server again from a second Mac terminal window, both terminals share a session. E.g. the windows start mirroring each other - what I type in one shows up in the other. This isn't what I want. I want separate sessions (so that, for example, I could tail example1.log in one window and example2.log in another window).

I also see this behavior if I login to the server once on my Mac, and a second time from a different Mac (e.g. it's definitely a server-side behavior, not something batty about my laptop).

Anybody know how to disable this behavior and go back to separate terminal sessions?

share|improve this question
2  
+1 This is the single most stupid preset I have ever seen for a multi-user system! :) –  Timo Mika Gläßer Nov 15 '11 at 19:29
add comment

1 Answer

up vote 5 down vote accepted

The first time you log in to the instance, enter this command:

byobu-disable

This will log you out and future logins will not be forced to share.

You can also learn to use screen if you want to use its advanced functionality, but the above is the easy way to get back to a sane default.

share|improve this answer
1  
Ah, god bless you. Order hath been restored to my universe. –  cailinanne Oct 26 '11 at 1:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.