Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So basically, I created a large windows server for development, and then I created a micro windows server for production. I set up everything how I wanted it on my development server, and then i unmounted the drives, and mounted them to my micro server.

Now I'm trying to get back into my large windows development server, and I'm getting the error.

Invalid value 'i-4896ce28' for instanceId. Instance does not have a volume attached at root (/dev/sda1)

this error pops up when I try to start my large windows server. I've remounted the drives to the large development server, and I still get this message.

I'm not really sure what to do, I've read other posts and everyone is giving these almost like command line arguments and talking about other tools, and I really have no clue what any of that means, or where I even have an option to enter any commands without be logged into a specific instance.

share|improve this question

migrated from Oct 26 '11 at 9:24

This question came from our site for professional and enthusiast programmers.

5 Answers 5

up vote 10 down vote accepted

Make sure the EBS-drive has the name /dev/sda1 in the EC2-Console.

share|improve this answer
It was confusing to me how they put on the botton of the attach device dialog that windows devices should be xvdg-xvdh..I wasn't aware I could just type in /dev/sda1. Thanks alot. –  Kyle Oct 29 '11 at 2:56
I've been there to; wouldn't know it otherwise ;) –  Bart De Vos Oct 29 '11 at 6:46
In my case I had to enter "/dev/xvda" in the input field as "/dev/sda1" kept leading to the same error message. Using Debian Wheezy image. –  Drake Enterprise Systems Oct 19 '14 at 6:55

You can try /dev/xvda. When you attach a volume to the instance -> select the particular instance then enter /dev/xvda for the mount point.

share|improve this answer

Make sure all of your volumes are detached before re-attaching. In my case I had a volume attached to an earlier snapshot. Once i detached that I was allowed to attach my new volume.

share|improve this answer

Under volumes > 'Detach volume' and then 'Attach Volume' and in the device field type the correct path. For example you might need to type: /dev/sda

share|improve this answer
+1 this actually worked for me, It boot up without any problems. –  Neo Mar 25 at 23:32

Make sure there is no leading space in '/dev/sda'

For some reason copying text out of the aws console often attaches a space in front of the string. A very annoying side effect that had me spinning my wheels for 15 minutes trying to get the primary drive on my production server remounted. I tried all of these solutions before figuring that out.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.