Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So I've followed these instructions to setup htaccess on my ubuntu 11

https://help.ubuntu.com/community/EnablingUseOfApacheHtaccessFiles

and yet I'm not able to get a directory with an .htaccess file containing the text "Options +Indexes" to list directories when viewed in the browser.

So what gives?

Or perhaps there a more recommended way to enable per-directory listing of the content?

There is nothing in the logs to hint about the problem, only warning about mod_rewrite trying to start 3 times, so perhaps there's yet another config that overrides the /sties_enabled/default one?

share|improve this question
    
AllowOverride in .conf file changed? To ...? –  Lazy Badger Oct 26 '11 at 13:54
    
AllowOverride changed to All –  Lech Rzedzicki Oct 26 '11 at 17:11
    
Everywhere? grep -i AllowOverride httpd.conf, please –  Lazy Badger Oct 26 '11 at 17:15
    
the change was made to /etc/apache2/sites-available/default and that in ubuntu 11 the httpd.conf is rather apache2.conf and that it doesn't have an AllowOverride setting in it. –  Lech Rzedzicki Oct 26 '11 at 17:28
    
Add explicitly to main server config AllowOverride All –  Lazy Badger Oct 26 '11 at 17:34

1 Answer 1

Extraction from functional conf

DocumentRoot "..."

<Directory />
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>
share|improve this answer
1  
Never, ever, EVER set AllowOverride All OR Allow from All on the OS root directory! –  adaptr Oct 26 '11 at 17:42
    
For server root, I must note... AllowOverride All isn't perfect for production, but usable for troubleshooting stage. Allow from All works nice, my paranoia agree with me –  Lazy Badger Oct 26 '11 at 17:48
    
Seriously? Remind me to avoid you in any professional capacity, then. –  adaptr Oct 26 '11 at 17:51
1  
adaptr: I want to get working first, then maybe secure it, besides, there is no one else using that server.That's how it is already - no warnings about parsing the conf files when restarting apache, so no typos, I think –  Lech Rzedzicki Oct 26 '11 at 17:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.