Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Remote Debian linux server which i access using Putty console either by IP or domain. That means server IP is pointing to hostname already for example: ->

I have installed Application called JIRA on remote server which is Apache based i guess. and i can access its website using I want to link this to

How can i do that? Any details with tutorial link will ofcourse help.

share|improve this question
What version of JIRA are you installing? 4.4.x or 5.0 Beta? – iainlbc Oct 27 '11 at 1:52
Its 4.4.3 on Debian 5 Linux. – sunny1 Oct 27 '11 at 7:36
I don't know where points for you, but where I'm at it's blocked because our system lists it as spyware. In the future, please use the name "example" for this kind of thing, as it's specifically reserved for that purpose. – Joel Coel Oct 27 '11 at 18:40
up vote 0 down vote accepted

JIRA runs as a standalone tomcat container out of the box. You can easily proxy to it from apache, I've only configured it as a separate subdomain and not a subdirectory of a site (ie. vs.

This is the tutorial I used to setup our apache => Jira config using mod_proxy:

To run it on a subdirectory like /jira, It may be as simple as doing this in your vhost:

ProxyPass /jira http://localhost:1080/
ProxyPassReverse /jira http://localhost:1080/

And setting the context path in conf/server.xml:

<Context path="/jira" docBase="${catalina.home}/atlassian-jira" reloadable="false">
share|improve this answer
Do i have to install Tomcat server other then standalone jira already running? I tried to configure context path /opt/atlassian/jira/conf/server.xml on server like it shows on documentation, but unfortunately the server is not accessing jira from Here is the line: <Context path="/jira" docBase="${catalina.home}/atlassian-jira" reloadable="false"> – sunny1 Oct 28 '11 at 1:05
Thanks its solved – sunny1 Oct 28 '11 at 5:25
One last question: How to set my domain instead of ? If website is already pointing to that will it work? Or there's any configuration? – sunny1 Oct 28 '11 at 5:28
Hi sunny, You won't need any additional config on the JIRA side of things. Just an A record with your domains DNS provider pointing to the server's IP and the ServerName attribute set in your vhost – iainlbc Oct 28 '11 at 18:39

You could also do this with NGINX if you only want to do this simple proxy without running a full web server.

server {
    listen 80 default;
    servername _;

    location /jira {
        rewrite ^/jira(.*)$ $1 break;
        proxy_pass_request_headers      on;
        proxy_set_header                Host            $http_host;
        proxy_set_header                X-Forwarded-For $remote_addr;
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.