Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am doing a lot of work using the XAMPP stack, but every time I restart my machine, I have to manually stop IIS before I can start Apache. I can't find a service for IIS to configure not start automatically.

How can I preven IIS starting automatically?

share|improve this question
add comment

3 Answers 3

up vote 4 down vote accepted

You have to disable two services:

  • World Wide Web Publishing Service (W3SVC)
  • IIS Admin Service (IISADMIN)

Go to Services, properties of the above mentioned services, change the start up type to "Disabled"

Enjoy.

share|improve this answer
1  
If you want to be able to run IIS, setting the start up type to "Manual" – and then use iisreset or a service control tool to start when required. –  Richard Oct 27 '11 at 7:22
    
agree with Richard. you can update the type to manual so you still able to start, instead of disabling it. –  Rudy Oct 27 '11 at 10:28
add comment

Look for World Wide Web Publishing Service (W3SVC) in services.

Also you could change the default port into something that does not conflict with Apache?

share|improve this answer
    
+1 for the port idea. I'll do that when I'm back to using both servers. –  ProfK Oct 27 '11 at 10:31
add comment
  1. Hit Windowskey-R (or click start -> run).
  2. Type in "services.msc"
  3. Double Click "World Wide Web Publishing Service" to view its properties
  4. On the first tab "General" you'll see a "Startup type" drop down box, set it to "Manual" or "Disabled".
share|improve this answer
    
don't forget to also disable the admin service (see Noor's answer) –  Kenny Rasschaert Oct 27 '11 at 9:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.