Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having problems with Basic Authentication in IIS 7.5.

I have:

  • enabled Basic Authentication on my site
  • disabled Anonymous Authentication on the same site
  • Added an IIS user and allowed said user to the site
  • Added read/write permissions for Basic Authentication on said site (feature delegation)

Its still not working. It prompts for username and password, but does not accept the user/pass i've created.

Any ideas?

share|improve this question
up vote 4 down vote accepted

"Added an IIS User" -> Do you mean IIS Manager user?

If so, these aren't real Windows users - just a username and a password in a text file somewhere: they don't have a SID or security tokens, and can't be used for Basic authentication. Not using the out-of-the-box configuration, anyway.

Create a (real) Windows user, and it'll be usable for Basic auth.


Edit: I just noticed you said something else - Feature Delegation doesn't describe permissions to the site contents, it's whether a non-Administrator can configure those features at a lower level within the site in a web.config file - essentially, which IIS feature icons are usable when they connect to the computer via the Management Service.

The answer is roughly the same, though:

  • reset delegation to defaults (you didn't mean to change it; it's dangerous to change some of the delegation settings from defaults under these conditions)
  • create a Windows user in Server Manager
  • assign permissions to that Windows user either at the file system level, or using the URL Authorization feature
share|improve this answer
Thank you. Its working now. Also, undid the feature delegation. – Andreas Berglund Oct 27 '11 at 9:36
Excellent! Glad you got it working. – TristanK Oct 27 '11 at 9:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.