Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are having trouble with emails sent from our new CentOS server running QMail. The email seem to loose new line characters in Outlook so the formatting is garbled while On other email clients the line spacing is doubled.

Outlook gives an error "extra line breaks were removed" but adding the extra breaks in outlook makes no difference to the formatting.

On our old webserver this was not an issue. No changes have been made to the php scripts that send the email.

I have tried some things like changing the new line character used in the email headers from \n to \r\n but it has not helped.

Does anyone know what can cause this and possible remedies we can try?

share|improve this question

1 Answer 1

  • Configure an email alias to deliver to both a mailbox that Outlook reads, and a local mailbox or maildir file on the mail server that is not touched by anything other than the mail system.
  • Send a test email that exhibits the problem in Outlook and compare the raw content (drag the Outlook message to disk, then open with a text editor) with the locally-stored copy on the mail server.

FYI email must use \r\n.

share|improve this answer
    
where should it use \r\n, in the headers, in the body or both? Using \r\n in the headers has made no difference. –  Ali Oct 28 '11 at 13:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.