Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm playing around with a test server, install Xen on a Centos 5 box.

I've tried two methods to create a vm.



virt-install -x " subnet="

If I do virt-install, it asks me this:

Automatic DHCP never works. If I try manual config, I have no idea what to put it. I did try this:

IPv4 address: / Gateway: Name Server: _____________________________________

note: only here in my post am I actually putting "xxx" in the IP for privacy reasons only. The 70.212 is the main server IP that I ssh into.

See 2nd screenshot for error. Same thing with various valid mirrors I tried.

This is my ifcfg-eth0 info:


I've tried 2 different mirrors so far, same error.

My resolvers are just fine too in /etc/resolv.conf

Note, I did not do anything at all. I had a fresh Centos 5 64bit install and then followed that Xen install guideline. That's it.

share|improve this question
You might consider accepting some answers on your previous questions prior to expecting results on this one :) – Tim Post Oct 15 '09 at 14:27
Its a Dell 850 actually. – Clear.Cache Jan 23 '11 at 9:50
up vote 1 down vote accepted

I've been building 64-bit Xen hosts on Dell 2850 and 2950s without problem... Looking at your virt-install option though I believe you want netmask=x.x.x.x rather than subnet=x.x.x.x as that's the only difference I see directly off hand.

If that is the only options to the command line you're using for virt-install you need to include a NIC using the -w option to add it to one or more of your Xen bridges. My typical call for virt-install is:

virt-install -n <hostname> -r <memory> -p --os-type=linux --os-variant=rhel5 \
-f /dev/xenvg/<hostname> -l http://KS-REPO/redhat/linux/enterprise/5/en/os/i386 \
--vcpus=1 -w bridge:xenbr0 --nographics --noautoconsole \
-x "ks=http://KS-REPO/ks/KICKSTART.KS ip=x.x.x.x netmask=255.255.255.x \
gateway=x.x.x.x dns=PRI-DNS-IP,SEC-DNS-IP"

In most cases I tend to have a 64-bit host but 32-bit guests... could modify to work with 64-bit guests if I needed to. This gives me 2 NICs (eth0 and eth1) attached to the xenbr0 and xenbr1 bridges respectively, single CPU guest installing a RHEL5 variant.

share|improve this answer
Not working, please help. Tried your method (note, the link you posted is not a valid domain anyway) Yours: Mine, Modified: – Clear.Cache Jun 30 '09 at 3:52
Okay... Can you provide the output of '/sbin/ip addr show'? It looks like your bridge names and mine don't match. The domain wasn't meant to be real as the Kickstart Repo (KS-REPO) I use is an internal mirror host you wouldn't have been able to reach. – Jeremy Bouse Jun 30 '09 at 10:39
Check out for an example I ran running a CentOS 5 x86_64 guest... Do check out the bridge names on your system as those might be different and I use LVM slices for physical drives for the VM rather than image files. – Jeremy Bouse Jun 30 '09 at 13:05
Thanks. This is the output. – Clear.Cache Jun 30 '09 at 15:50
Looks like you only have the one bridged NIC as xenbr0 while I have both xenbr0 and xenbr1... You can confirm with the 'brctl show' command I showed in my paste URL. – Jeremy Bouse Jul 1 '09 at 1:17

If you happen to have a Dell 2950 (or any other Dell x9xx using a Broadcom NetXtreme II) I suggest that you follow

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.