Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 servers connected to my router. One is running Windows Server 2008 R2 and the other is running Ubuntu. I have port 80 open on my router and sending traffic to Ubuntu. I have port 801 open and sending traffic to my Windows Server.

My question is, what do I need to do in IIS on the windows server that will allow it to serve pages correctly on port 801. Right now, I have it binding to my public IP address and I keep getting "Server is taking too long" errors in Firefox.

share|improve this question
    
Can you clarify how your IIS bindings are configured? –  Shane Madden Oct 27 '11 at 19:24
    
Im new to IIS, so im not actually sure what that means. But this is a fresh install of Windows Server, so whatever the defaults would be. Is there a way I can provide better info? –  user489041 Oct 27 '11 at 19:25
    
"open" might mean a couple of things - if you're forwarding port 801 to the IIS server's internal IP on port 80, you don't need to change your default bindings in IIS (unless your applications build URLs using what they think is the correct IP and port combination). –  TristanK Oct 28 '11 at 2:01
add comment

3 Answers

You need to configure the bindings for the web site in IIS for port 801.

http://technet.microsoft.com/en-us/library/cc731692(WS.10).aspx

share|improve this answer
add comment

In the IIS manager, select the site that you want to modify the bindings for - in your case, it's probably just the "Default Web Site".

On the right side, under "Actions", one of the options is "Bindings...":

bindings

There, you can see the bindings that are configured - each has a scheme (http/https), IP (which, by default, uses all addresses bound to the system), and port, and may also have a host header.

For your needs, you'll probably just need to configure a new binding on port 801, with no host header restriction:

new

share|improve this answer
    
Thanks for the response. I have the window up right now. I have it just like the one above. I left IP adress: All Unassigned and put in port 801 as the port. It works if I type in 'localhost:801' in a web browser on my server. However, say my external IP is '66.186.35.223' and I type '66.186.35.223:801' into my browser, I get 'The connection has timed out' –  user489041 Oct 27 '11 at 19:49
    
@user489041 Are you doing that from behind the same router? You'd need the NAT to translate the connection coming from inside, which most NAT devices don't do, or aren't set up for by default. –  Shane Madden Oct 27 '11 at 19:59
    
Nope, I am trying to access it here at the office and still can get through. I cant even ping it. –  user489041 Oct 27 '11 at 20:06
    
Using ping as a diagnostic tool without knowing for sure that you should get a response (due to firewalls blocking ICMP traffic) is a red herring. I never use ping to check host connectivity or availability unless I know for sure that I should recieve a response. Too many times people think that because ping doesn't respond that there's a problem with their host/service without knowing whether or not ICMP traffic is allowed to the host in the first place. As for the site bindings, try stopping and restarting the web site. –  joeqwerty Oct 27 '11 at 20:24
2  
The best way to test an HTTP service is with an HTTP request. –  joeqwerty Oct 27 '11 at 20:31
show 1 more comment

netsh http add iplisten address=x.y.z.i

http://serverfault.com/a/551218/92108

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.