Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't kill the nginx processes. There's something running with python:

python /usr/lib/python2.5/site-packages/producer.pyo --type=nginx

and master and worker processes and running. I don't know how to kill that. see with this command sudo ps -ef | grep -i nginx

Output:

amer@stream14:/etc$ sudo ps -ef | grep -i nginx
root      3031     1  0 Oct27 ?        00:01:09 python /usr/lib/python2.5/site-packages/producer.pyo --type=nginx
root     16271 16254  0 May24 ?        00:00:00 supervise nginx-purge
www-data 17148     1  0 Oct27 ?        00:00:00 nginx: cache manager process
www-data 17296     1  0 Oct27 ?        00:00:00 nginx: cache manager process
www-data 17347     1  0 Oct27 ?        00:00:00 nginx: cache manager process
www-data 18131     1  0 Oct26 ?        00:00:00 nginx: cache manager process
www-data 20202     1  0 01:00 ?        00:00:00 nginx: cache manager process
www-data 20256     1  0 01:01 ?        00:00:00 nginx: cache manager process
www-data 20298     1  0 01:01 ?        00:00:00 nginx: cache manager process
root     20989 16254  0 01:18 ?        00:00:00 supervise nginx
root     21048 20989  0 01:19 ?        00:00:00 nginx: master process nginx
www-data 21050 21048  0 01:19 ?        00:00:00 nginx: worker process
www-data 21051 21048  0 01:19 ?        00:00:00 nginx: worker process
www-data 21052 21048  0 01:19 ?        00:00:00 nginx: worker process
www-data 21053 21048  0 01:19 ?        00:00:00 nginx: worker process
www-data 21054 21048  0 01:19 ?        00:00:00 nginx: cache manager process
www-data 21055 21048  0 01:19 ?        00:00:00 nginx: cache loader process
root     21137 16254  0 01:20 ?        00:00:00 supervise accounting-nginx
root     21138 21137  3 01:20 ?        00:00:00 python /usr/lib/python2.5/site-packages/producer.pyo --type=nginx
amer     21143 17462  0 01:20 pts/0    00:00:00 grep -i nginx
share|improve this question
add comment

1 Answer

It looks like you're using daemontools to supervise nginx. It's not recommended in a production mode. To stop it, just down the nginx service:

# svc -d /path/to/nginx/service

or stop the supervise process:

# /etc/init.d/svscan stop

and turn on (or comment out) the daemon directive in Nginx configuration file.

share|improve this answer
    
From your linked nginx documentation: "You can use daemon off safely in production mode with runit/daemontools, however you can't do a graceful upgrade. master_process off should never be used in production." –  sr_ Oct 28 '11 at 9:34
    
Hi quanta, Its not working :(. i located nginx on: /usr/local/aflexi/etc/nginx i tried to run daemontools commands but no use. This link did'nt help as well articles.slicehost.com/2009/8/3/… now i'm getting frustrated because of it. please, any idea? –  sunny1 Oct 29 '11 at 1:12
    
No. You need to find the location where nginx is started under daemontools (for e.g: /service/nginx/run). What is the output of /etc/init.d/svscan stop? –  quanta Oct 29 '11 at 2:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.