Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running a local centOS machine; GLAMP. Recently I've started running into an issue with LAG.


  • Everything is SSL
  • Local Windows Server 2008 is DNS [for clients to reach centOS box]
  • every 2-3 requests >5s wait on request to response [on dynamic content as well as with static text]
  • does not seem to occur with using IP address instead of hostname
  • Local install, I'm the only one connecting

I've restarted all the relevant services. I've rebooted the centOS machine.

There isn't much in the logs besides this:

Invalid method in request \x16\x03\x01

This is coming from the Windows [DNS] box. In that machines EventViewer, the only thing that hits on the IP address of the centOS box is a DCOM error:

DCOM was unable to communicate with the computer using any of the configured protocols.

System monitor on DNS doesn't show anything remarkable.

I can't forego this Windows Server acting as DNS.

Is there a way to pinpoint that DNS is the problem and fix it?



It appears to be an issue with Firefox and Chrome on my computer (OS X Lion). Safari appears to not have the issue. All extension disabled; DNS server is ONLY set to the aforementioned Server 08 box. Holy crap is this frustrating...

It is strange that it seems to constantly be 5.18s total duration on the requests that take longer (1 out of every 3 or 4)

share|improve this question
up vote 0 down vote accepted

It is Chrome behaving badly...

As it turns out, it wasn't Chrome's fault (duh).

There is another machine that acts as sql server to which the apache box speaks. They are connected only to each other and on a separate subnet from everything else. Sometimes, for some reason I couldn't find, the sql box would be trying to resolve names and the servers in resolve.conf were inaccessible. After modifying resolve.conf things are snappy again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.