Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an website hosted on IIS 7 as http://mywebsite.com. Works fine and publicly accessible.

I now created a https://mywebsite.com/newapplication with self sign certificate. I can access the https://mywebsite.com/newapplication on local network but not outside the local network. However if I disable the SSL certificate , I can access http://mywebsite.com/newapplication.

Whats causing the problem to access https website externally. any idea or solution ..???

Its very urgent...!!!!

share|improve this question

migrated from stackoverflow.com Oct 28 '11 at 18:22

This question came from our site for professional and enthusiast programmers.

closed as too localized by Shane Madden, Chris S, Zoredache, mailq, voretaq7 Oct 28 '11 at 19:46

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
Are you behind a NAT router? Did you remember to forward port 443? –  Dan Herbert Oct 28 '11 at 18:11
2  
Or even firewall on server? –  Rippo Oct 28 '11 at 18:13
    
https uses a different port 443 to http which uses port 80. Lots of organisations block all ports apart from port 80. If your the admin, open up the extra port to the server. –  JonAlb Oct 28 '11 at 18:15
    
How to find if I am behind NAT ..??? Port 443 is forwarded in my windows 2008 machine . –  bp581 Oct 28 '11 at 18:16
    
I disabled the firewall to test..still does not work –  bp581 Oct 28 '11 at 18:17

1 Answer 1

up vote 3 down vote accepted

Gotta open that port 443 in your external-facing firewall.

share|improve this answer
    
Dos that mean I have done all I can , its some thing network administrator needs to fix ??? –  bp581 Oct 28 '11 at 18:21
1  
The problem is resolved.....!!I spoke to network administrator at our organization and requested to open port 443. Appreciate all the responses..it helped me troubleshoot the problem. –  bp581 Oct 28 '11 at 18:57
    
@bp581 - I lost power on my phone while writing, thus the absence of further comments. Glad you figured it out :) –  Peter Lillevold Oct 28 '11 at 22:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.