Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed and setup Bugzilla3 for my domain. Everything is working properly except for the email functionality.

The server uses Postfix, and that works for my PHP application, and command line.

In Bugzilla, I have tried setting the mail_delivery_method to 'test', and nothing shows up in data/mailer.testfile, it is completely blank...

I have no idea where to go from here, any ideas on what to try next?

share|improve this question
Look into the log files. What's there? – mailq Oct 29 '11 at 20:25
Absolutely nothing, zilch, nada. The mail.log files shows no activity, and the data/mailer.testfile still contains nothing (even though the purpose of the file is to display Bugzilla 'test' emails). – donutdan4114 Oct 29 '11 at 20:29
So then I would file a bug in the bugzilla of bugzilla. – mailq Oct 29 '11 at 20:34
Yes I file bugs, and change them to try and generate some emails, does not work. – donutdan4114 Oct 29 '11 at 20:59
1. Check the status of jobs in queue: /etc/init.d/bugzilla.queue 2. fire, tail -f /var/log/maillog – user228067 Jun 26 '14 at 11:47

Check you have given a valid email address in "mailfrom" parameter.

I also have this similar issue, after I gave a valid email address it worked fine.

Additional Information:

I have installed postfix in my system and selected "Sendmail" in mail_delivery_method.

share|improve this answer

When you change bugs, does Bugzilla tell you that it is sending mail? By default, if you change a bug, mail is not sent to you, only to other people - and if you are the only user of your Bugzilla, that would be no-one :-)

To force a mail to be generated, ask for a password reset and then check the mailer.testfile.

Which version of Bugzilla are you using?


share|improve this answer
Version 3.something. I have it set to send mail, and when I edit/change bugs it tells me its sending an email to my address. Even on testing though it doesn't show anything in the test file... I will test the password reset and get back to you. – donutdan4114 Nov 1 '11 at 0:30
donutdan: any news? – Gervase Markham Dec 14 '11 at 10:16
have not been able to get it to work yet... Not too worried about it however, we are surviving without the email functionality. – donutdan4114 Dec 19 '11 at 14:10

I know this must have been resolved by now, but I had a similar issue where I couldn't find the mailer.testfile and had just assumed it wasn't being created.

It turns out I was looking in the wrong directory.

The correct (default) location for this file is:


Originally I was looking in a data directory I created under:

share|improve this answer

Faced same issue, bugzilla was showing that it sent the email but nothing was received

fixed by setting: use_mailer_queue to "off"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.