Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a PHP script that sends emails using PEAR mail. However on my new server it is not sending the majority of emails.

Postfix is the mail server and opensuse 11.4 is the os.

My Postfix does not receive email, just sends. I have a bluehost account for receiving mail. I have a relay hash with egeneration.com.au and senderdomain.com listed. My postconf is below:

biff = no
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
debug_peer_list = egeneration.com.au
html_directory = /usr/share/doc/packages/postfix-doc/html
inet_protocols = all
mail_owner = postfix
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
myorigin = egeneration.com.au
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix-doc/README_FILES
relay_domains = $mydestination, hash:/etc/postfix/relay
sample_directory = /usr/share/doc/packages/postfix-doc/samples
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
unknown_local_recipient_reject_code = 450
virtual_alias_maps = hash:/etc/postfix/virtual

The log when trying to send an email from senderdomain.com is below:

Oct 30 09:55:34 i-1356-3913-VM postfix/pickup[21809]: 6AF4D814D5: uid=30 from=<wwwrun>
Oct 30 09:55:34 i-1356-3913-VM postfix/cleanup[21819]: 6AF4D814D5: message-id=<20111029225534.6AF4D814D5@i-1356-3913-VM.localdomain>
Oct 30 09:55:34 i-1356-3913-VM postfix/qmgr[21810]: 6AF4D814D5: from=<wwwrun@egeneration.com.au>, size=1328, nrcpt=2 (queue active)
Oct 30 09:55:35 i-1356-3913-VM postfix/smtp[21822]: 6AF4D814D5: to=<info@senderdomain.com>, relay=mail.senderdomain.com[70.40.219.35]:25, delay=0.94, delays=0.07/0.01/0.6/0.26, dsn=5.0.0, status=bounced (host mail.senderdomain.com[70.40.219.35] said: 550-Verification failed for <wwwrun@egeneration.com.au> 550-No Such User Here" 550 Sender verify failed (in reply to RCPT TO command))
Oct 30 09:55:36 i-1356-3913-VM postfix/smtp[21821]: 6AF4D814D5: to=<recipient@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.53.26]:25, delay=1.9, delays=0.07/0.01/0.7/1.2, dsn=2.0.0, status=sent (250 2.0.0 OK 1319928936 e9si13946802pbd.228)
Oct 30 09:55:36 i-1356-3913-VM postfix/cleanup[21819]: 5857F814D6: message-id=<20111029225536.5857F814D6@i-1356-3913-VM.localdomain>
Oct 30 09:55:36 i-1356-3913-VM postfix/qmgr[21810]: 5857F814D6: from=<>, size=3500, nrcpt=1 (queue active)
Oct 30 09:55:36 i-1356-3913-VM postfix/bounce[21823]: 6AF4D814D5: sender non-delivery notification: 5857F814D6
Oct 30 09:55:36 i-1356-3913-VM postfix/qmgr[21810]: 6AF4D814D5: removed
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 220-box351.bluehost.com ESMTP Exim 4.76 #1 Sat, 29 Oct 2011 16:55:37 -0600 
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 220-We do not authorize the use of this system to transport unsolicited, 
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 220 and/or bulk e-mail.
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: > egeneration.com.au[70.40.219.35]:25: EHLO i-1356-3913-VM.localdomain
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 250-box351.bluehost.com Hello i-1356-3913-VM.localdomain [125.7.120.34]
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 250-SIZE 52428800
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 250-PIPELINING
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 250-AUTH PLAIN LOGIN
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 250-STARTTLS
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 250 HELP
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: server features: 0x101d size 52428800
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: Using ESMTP PIPELINING, TCP send buffer size is 4096
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: > egeneration.com.au[70.40.219.35]:25: MAIL FROM:<>
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: > egeneration.com.au[70.40.219.35]:25: RCPT TO:<wwwrun@egeneration.com.au>
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: > egeneration.com.au[70.40.219.35]:25: DATA
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 250 OK
O    ct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 550 No Such User Here"
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: connect to subsystem private/bounce
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr nrequest = 0
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr flags = 0
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr queue_id = 5857F814D6
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr original_recipient = wwwrun@egeneration.com.au
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr recipient = wwwrun@egeneration.com.au
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr offset = 194
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr dsn_orig_rcpt = 
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr notify_flags = 0
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr status = 5.0.0
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr diag_type = smtp
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr diag_text = 550 No Such User Here"
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr mta_type = dns
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr mta_mname = egeneration.com.au
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr action = failed
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: send attr reason = host egeneration.com.au[70.40.219.35] said: 550 No Such User Here" (in reply to RCPT TO command)
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: private/bounce socket: wanted attribute: status
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: input attribute name: status
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: input attribute value: 0
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: private/bounce socket: wanted attribute: (list terminator)
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: input attribute name: (end)
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: 5857F814D6: to=<wwwrun@egeneration.com.au>, relay=egeneration.com.au[70.40.219.35]:25, delay=1.1, delays=0.07/0/0.79/0.24, dsn=5.0.0, status=bounced (host egeneration.com.au[70.40.219.35] said: 550 No Such User Here" (in reply to RCPT TO command))
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 503-All RCPT commands were rejected with this error:
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 503-No Such User Here"
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 503 Valid RCPT command must precede DATA
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: > egeneration.com.au[70.40.219.35]:25: RSET
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: > egeneration.com.au[70.40.219.35]:25: QUIT
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: < egeneration.com.au[70.40.219.35]:25: 250 Reset OK
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: name_mask: resource
Oct 30 09:55:37 i-1356-3913-VM postfix/smtp[21822]: name_mask: software
Oct 30 09:55:37 i-1356-3913-VM postfix/qmgr[21810]: 5857F814D6: removed

Can anyone please help me please?

UPDATE: I have created a mailbox on bluehost.com for wwwrun@egeneration.com.au and tested again and it seems to go through ok. Is there a way I can tell Postfix to use the sender's address rather than wwwrun@egeneration.com.au?

share|improve this question
    
You shall not edit your question to create another question. This way you will not receive answers. At least not from me. –  mailq Oct 30 '11 at 12:04

1 Answer 1

up vote 0 down vote accepted

You haven't configured your Bluehost domain "egeneration.com.au" to accept mails for the user named "wwwrun". Correct that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.