Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This has been kicking my butt for some time now and i'm reaching out for help. Here is the scenario: There is 1 Exchange 2003 server which lives on It has 1 SMTP Virtual server and 1 SMTP Connector. The connector is configured to forward all mail through an external spam filter.

What I am looking to do is setup a ticket system (JIRA), which will live in a virtual machine on the same LAN as Exchange and should receive only internal mail destined for So i will have a distribution list on exchange - which will have a contact member From what i've read i need another SMTP connector configured on exchange in order to process outgoing mail destined for Postfix will be the receiving mail server for So far, i am struggling to see any indication of mail being routed to Postfix, but there are no bounces. Please let me know what you think. Here is my attempt at a diagram :)

Problem: I am unable to get exchange to forward to postfix.

Question: What is the best way to verify that exchange is actually trying to deliver the message to Postfix and does not drop it?

Question #2: In the descried scenario, would exchange be considered a "relay" for postfix? Thanks so much in advance!

Exchange is configured to send email via a smarthost

share|improve this question
So what is the question? – mailq Oct 30 '11 at 0:16
I am unable to get exchange to forward to postfix. – tbapb Oct 30 '11 at 0:20
This is not a question, this is a statement. – mailq Oct 30 '11 at 0:28
Touche. Do i need an additional smtp connector or can i achieve this with only one? If so, what is the correct connector config to achieve the desired results? Thanks – tbapb Oct 30 '11 at 0:56

A couple of things:

  1. Exchange Server 2003 isn't automatically authoritative for subdomains, which is what is.

  2. There are a few different ways to accomplish what you need, detailed here:

A third method, which I think is easier would be:

  1. Create an internal DNS zone for

  2. Create an A record for the Postfix server in the zone.

  3. Create an MX record in the zone that points to the Postfix A record.

This method leaves your Exchange server unencumbered regarding the Recipient Policy and SMTP connector. I think this is cleaner and simpler. The only caveat is if you have an external subdomain in the DNS zone for jira ( then internal resolution of DNS RR's for are going to break.

share|improve this answer
Thanks, this is great stuff. I had missed one configuration step where a new Recipient policy is created. I am still however unable to see any indication of mail delivery in postfix logs (/var/log/maillog). What is the best way to verify that exchange is actually trying to deliver the message to Postfix and does not drop it? – tbapb Oct 30 '11 at 7:01
Use the Message Tracking tool in ESM to track the message and look at the SMTP log on the Exchange server to follow the SMTP conversation. – joeqwerty Oct 30 '11 at 14:59
These are the last few lines of the logs in Message Tracking for the message in question: SMTP:Message delivered locally to multiple recipients SMTP Store Driver: Message delivered locally to store to However, there is no indication of message delivery to – tbapb Oct 30 '11 at 17:58
So the email is getting hung up at the external spam filter, which it shouldn't using method 3 unless Exchange is configured to send email via a smarthost. Is that the case? – joeqwerty Oct 30 '11 at 21:49
OK, do me a favor. Get everything back to their original settings. Get rid of the Recipient Policy, the Contact, the SMTP connector, and the DNS zone for Then send an email from your AD account to You should get an NDR stating "The destination server for this recipient could not be found in Domain Name Service". If you do then we'll know we're back at square one and can start again from the beginining. – joeqwerty Oct 31 '11 at 3:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.