Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I just installed XAMPP 1.7.7 on Windows Server 2003 r2 and enabled the php_ldap extension in php.ini Now, when starting the service, it hangs on 'starting'

Aditional info: Since XAMPP 1.7.5+ is compiled with VC9 in stead of VC6 the modules got changed aswell, I suppose it's a compilation bug that I can't use the php_ldap function.

What can I do to fix this? I don't get any kind of error.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Just run httpd.exe from the command line and see that it cannot find libsasl.dll.
Copy it from /php directory to /apache/bin, restart the apache server and enjoy.
Other possible dll's that you might need to copy are libeay32.dll and ssleay32.dll

Related read: Solved PHP LDAP error - Fatal error: Call to undefined function ldap_connect()

share|improve this answer
    
After turning on LDAP on my Windows 7 local host for a Drupal 7 install and I was getting an arror about missing MSVCR80.dll. Tried a bunch of stuff to get this dll installed with no success. Stumbled on this post and copied libsasl.dll in the apache/bin and voila, problem went away. –  user138740 Sep 27 '12 at 18:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.