Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I run a Windows 2008 server with SP2. This server acts as a desktop alone. Recently, I switched between two networks (corporate and other) using this system. Ever since, I am unable to access any network share on the original network from where I installed and configured the desktop. The message I get is "Network path was not found". Note that I am able to access the internet and my corporate mail server.

I am told this is a Vista and Windows 2008 specific problem and I have done everything I could think of: a) Deleted the second network settings from the desktop b) Installed a patch from MS that supposed took care of this problem (with MS clearly saying they had not tested this enough) c) The SP2 install was after the problem occurred and I went ahead with it in the hope that SP2 may have something that would fix this

Some additional details:

a) A system admin can log into this system from a remote terminal b) I cannot get into my own system using the hidden share C$ - for instance \mymachine\C$ gives me the same message as above - Network path not found c) I can log into my system remotely using mstsc d) I cannot create shares on this system - as an extension network printers are not detected

I have an update for you: The error message is as follows -

**Network Error**

Windows cannot access \\network_share

Check the spelling of the name. Otherwise there might a problem with your network. To try to identify and resolve network problems, click Diagnose.

Clicking Diagnose gives Error Code: 0x80070035 The network path was not found.

Any help will be appreciated

Thanks

share|improve this question

9 Answers 9

In Vista/Server 2008, each network has its own profile, and you'll need to enable File and Print Services(netbios services) for each network.

For more help, try these two links: Enable File and Printer Sharing and File and Print Sharing in Vista

hth, ~H

share|improve this answer

For me :

  • Server 2008 Standard (not R2)
  • Firewall is off
  • Computer browser service is on
  • I am trying to access \\MYMACHINE\TFS-BUILDS because TFS requires a UNC share for drops
  • (I am accessing both by typing in the name and double clicking the folder)
  • Single network card
  • Filesharing wizard says share was ok
  • Share was showing under 'computer management'
  • No obvious errors in eventlog
  • Reboot didn't fix it

How did I fix it? I haven't :-(

I'll update this when I figure it out!

Edit: FIXED IT !!

Apparently 'File and printer Sharing for Microsoft Networks' is not installed for the network adapter by default. This is independent on whether or not file sharing is actually installed. I'm not sure if this is a Windows 2008 default or the network card's default.

So here's what fixed it:

  • Right click on 'Local Area Connection'
  • Verify that 'File and Printer Sharing for Microsoft Networks' is NOT there
  • Assuming you don't see it - Click 'Install'
  • Double click on 'Service'
  • Select 'File and Printer Sharing for Microsoft Networks'
  • Click OK to install it
  • Reboot machine

You should be able to see it now. Jees! (Answer from http://kadaitcha.cx/file_sharing.html)

share|improve this answer

You are not crazy I have this issue too and can replicate the following oddies that only seem to happen with win2k8 sp2 and vista sp2 clients whom are not joined to the domain but try to access a domain joined server. They will get prompted for cred's but even when the creds are correct will not be allowed access. Interestingly enough however if you attempt to connect via \ip\ or \ip\share you are prompted for creds and they work and access is granted but if you use the standard \machinename or \FQDN while you get prompted, it will never let you in.

This seems to have started with SP2. I have found no solution to this other than rolling back to SP1 or using the IP. Also interesting is once you have connected via IP successfully you can then use the \machinename etc methods and they work fine. If you then say remove all connections to the box via net use /del on all connections then try the \machinename again the problem will return. - Almost hilarious

Makes no logical sense to me why this is, but it is.

share|improve this answer

What worked for me was turning on "TCP/IP NetBIOS Helper" in services. Somehow that was set to run automatically but was not turned on. After i started the service I was able to connect to shares.

share|improve this answer

Did you check if the Windows firewall is blocking the ports needed by File Sharing? To enable the File and Printer Sharing option in Windows Firewall Configuration Settings:

  1. Start > Control Panel > Network and Intranet
  2. Under the Windows Firewall section heading, click the "Allow a program through Windows Firewall" link
  3. In the programs and ports list, check the "File and Printer Sharing option"

Check also in the Network and Sharing Center (from Control Panel), if "File Sharing" is "on".

share|improve this answer

From the servicess check the Computer Browser service... I had the same problem and apparently this was the couse. I think by default this servise is disabled

share|improve this answer

Fixing the winsock and TCP/IP worked for me. On the run command (as admin) I used the following commands:

for winsock run: netsh winsock reset

to reset tcp/ip run: netsh int ip reset c:\temp\resetlog.txt

Cheers, Thomas

share|improve this answer

This Solution Fixed my problem:

You are not crazy I have this issue too and can replicate the following oddies that only seem to happen with win2k8 sp2 and vista sp2 clients whom are not joined to the domain but try to access a domain joined server. They will get prompted for cred's but even when the creds are correct will not be allowed access. Interestingly enough however if you attempt to connect via \ip\ or \ip\share you are prompted for creds and they work and access is granted but if you use the standard \machinename or \FQDN while you get prompted, it will never let you in.

This seems to have started with SP2. I have found no solution to this other than rolling back to SP1 or using the IP. Also interesting is once you have connected via IP successfully you can then use the \machinename etc methods and they work fine. If you then say remove all connections to the box via net use /del on all connections then try the \machinename again the problem will return. - Almost hilarious

Makes no logical sense to me why this is, but it is. link|flag

share|improve this answer
  • This combination of machines has run for some years without difficulty.
  • I changed Internet service provider (to a cable-based system). Everything works fine. Noticed that time to log into one Windows Server 2008 (of two) on my small private network was several minutes for each step (Applying User Settings, etc). Domain controller (the other server) could be logged onto instantly. An Internet suggestion caused me to remove the ailing server from the domain, then attempt to rejoin. Failed consistently: "The network path was not found." Tried various things for a long time. Decided to clean install Windows Server 2008 R2 on the domain controller. This went fine. Attempting to join the untouched server #1 (IIS) to new DC failed in exactly the same way: "network path was not found." Each server can ping the other, even by name. DC can sometimes see IIS in network browsing, but IIS can never see DC (it does see one non-domain-connected workstation). DCDiag shows no problems. Was able to map DC on IIS as network location. No effect on failure to join domain. Windows Firewall currently off on both servers. Began following ServerFault suggestions.
  • Network discovery is "Custom," and File Sharing is On. Started the disabled Computer Browser service. More computers appeared in network discovery but had no effect on joining the domain.

Did the winsock and tcpip resets (via Thomas). This was scary, because it deleted all my NIC settings. But, lo and behold, restoring them yielded the long sought "Welcome to the ... domain!"

[I attempted several times to format most of the points above as bullets, but it all ran together. Other than that, ServerFault Rules!]

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.