Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I connect to a VPN with openvpn which sets my DNS to the Google DNS servers ( and For some reason this does not work on a linux client, only on windows (the effect is that I can't resolve any domain names while connected to the VPN). I would like to disable this feature on the linux client (so it uses its own DNS configuration). How can I do it?

share|improve this question
up vote 1 down vote accepted

Gnome's network manager with OpenVPN lets you only get Addresses from the VPN server and have your own DNS server and search domains be configured. Not sure if your requirement is for a Desktop System or a server and what desktop environment you are using.

But, there exists a case where you might not be able to access your own DNS service (from the one provided by your service provider) because all your traffic including DNS'es would be routed from the VPN server. In this case you can manually set google's free DNS server addresses there.

Not sure if you are using network-manager's OpenVPN module to configure VPNs. But that would be a better way.

Also this script/tutorial might be of help to you.

share|improve this answer
Thanks! What I did was dissect the openvpn configuration file (save keys into their own files etc.) and configure the gnome network manager by hand (instead of executing openvpn on the command line). Now it works as intended. – Tamás Szelei Nov 2 '11 at 12:44

Remove the line "push "dhcp-option DNS" " from a server, or create a separate ccd files.

share|improve this answer
I don't have access to the server. – Tamás Szelei Nov 1 '11 at 13:17
After connecting your linux box to the vpn, try to manualy set dns servers that belong to a vpn routed network, and see if it's working. – Boban P. Nov 1 '11 at 13:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.