Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have tried installing MCollective on the latest version of Ubuntu, and out of the box, it does not seem to be working. I am curious what I have missed, and where the correct place to file a bug is, assuming it is a bug.

Steps so far:

$ apt-get install mcollective-middleware mcollective mcollective-client
$ mc-find-hosts 
/usr/lib/ruby/1.8/mcollective.rb:1:in `require': no such file to load -- rubygems (LoadError)
    from /usr/lib/ruby/1.8/mcollective.rb:1
    from /usr/sbin/mc-find-hosts:3:in `require'
    from /usr/sbin/mc-find-hosts:3

At this point, it looks like the rubygems package should have been listed as a dependency. OK, so lets install that:

$ apt-get install rubygems
$ mc-find-hosts
$

Now it is just failing silently after a short delay.

Anyone experienced this or know of a way to solved it?

share|improve this question
    
try putting sudo infront maybe? –  codecompleting Nov 1 '11 at 20:03

1 Answer 1

up vote 0 down vote accepted

To fix the "silence", I restarted the mcollective service and things are now working as expected.

It looks like the package dependencies are a little messed up on Ubuntu 11.10 oneiric.

I have submitted a bug report: https://bugs.launchpad.net/ubuntu/+source/mcollective/+bug/884908

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.