Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having an issue installing IIS 7 on a machine that has a brand new install of Vista Ultimate x64.

I've tried using the Turn Windows Features On or Off feature in the Programs and Features control panel. It seems to hang for ages before the progress bar finally starts moving. The progress bar appears to reach 100% but then I get the error message:

"An error has occurred. Not all of the features were successfully changed."

Upon checking the *Turn Windows Features On or Off" control panel, IIS is not highlighted; Further to this, when I go to http://localhost/ I get the "Diagnose Connection Problems" page. Checking the Services Control Panel shows that the IIS Admin Service is not installed and neither is the Web Publishing Service.

I've managed to install/uninstall/reinstall the Windows Process Activation Service as suggested by Technet, and I've also attempted to follow the command line instructions found on the learn IIS website at:

http://learn.iis.net/page.aspx/132/install-iis-7-from-the-command-line

This process appears to hang forever before finally completing too. I get no indication as to whether or not the process was successful until I use the command:

echo %errorlevel%

Which returns error 1603. After Googling this for a bit, I have no conclusive information as to how to go about figuring out what the problem is, nor of how I go about fixing it.

If I could even determine what is causing the problem, I would probably be able to figure out how to fix it.

If anyone could give me some insight, it would be greatly appreciated.

share|improve this question
add comment

2 Answers

The error code you mention (1603) seems to be a windows installer error code, there is a kb article about that error at http://support.microsoft.com/kb/834484

Have you tried looking at the event log as Kibbee suggested?

There's also the installation log file for iis7 located at %windir%\iis7.log which should provide more insight about the problem.

share|improve this answer
add comment

Did you try looking in the event log under the administrator tools to see if there was any other errors reported?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.