Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is there a way turn off the automatic snapshot feature in vmware server? (Or is that a bad idea for some reason?) We have the files on the machine backed up separately, so I don't see the need for snapshots, and it seriously slows down the host system when it runs.

share|improve this question

2 Answers 2

[Update: The following answer works, but I found a better solution which I posted also.]

Although I did not find a way to shut off the automatic snapshot feature (which seems to be called autoprotect) completely, I did find a way to extend the interval between the snapshots to 10 years (or any other time) which essentially the same thing. The .vmx file for the machine contains a line:

snapshot.numRollingTiers = "3"

which means there are three timers that control the frequency (and other things) of the automatic snapshots. Below that line you will see lines starting with "rollingTier0", rollingTier1, and rollingTier2, which are the configuration for the timers. The rollingTier[n].interval line contains a number of seconds to wait between snapshots. The default for rollingTier0.interval is 3600, so a snapshot happens every hour. I put in a value of 315567360 for this one:

rollingTier0.interval = "315567360"

so it runs every 10 years, and made the others slightly longer.

If you edit the vmx file directly, be sure to power off the virtual machine first, per this page. My sys admin actually made the change using the web-based client for vmware server that lets you configure the virtual machines.

share|improve this answer
up vote 0 down vote accepted

The automatic snapshot feature (which seems to be called autoprotect) is controlled by the "rollingTier" lines in the .vmx file. The .vmx file for the machine contains a line:

snapshot.numRollingTiers = "3"

which means there are three timers that control the frequency (and other things) of the automatic snapshots. Below that line you will see lines starting with "rollingTier0", rollingTier1, and rollingTier2, which are the configuration for the timers.

In my previous answer to this question I suggested increasing the "interval" settings of the rolling timers to something large (like 10 years). That works, but I then found a way to turn them off completely. If you set the rollingTier[n].live lines to false, e.g.

rollingTier0.live = "false"

(and also for rollingTier1 and rollingTier2) then the timers simply won't run.

Note: If you edit the vmx file directly, be sure to power off the virtual machine first, per this page. My sys admin actually made the change using the web-based client for vmware server that lets you configure the virtual machines.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.