Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set a wallpaper for all users of my AD through a group policy:

User Configuration -> Policies -> Administrative Templates -> Desktop -> Desktop Wallpaper

This wallpaper is shown for the first time a user logs on, but if he does not log off and just disconnects the RDP connection and reconnects with RDP the default Windows Server 2008 background is shown.

Does anyone know what I am doing wrong?

I am running Windows Server 2008 R2 on both, the machines where users logon and the Active Directory Controller.

EDIT: I have encountered the following behaviour: After the first login the registry value

HKCU\Control Panel\Desktop\Wallpaper

contains the following:

C:\Users\UserXYZ\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper.jpg

which is essentially the Windows Server 2008 R2 standard wallpaper. If I override this setting by hand and set it to my custom wallpaper, everything works fine, after each disconnect and new logon!

share|improve this question
add comment

4 Answers

I had the same problem, not just on RDP but also on computers. I found a solution which is adding a policy to set a registry setting (Preferences -> Windows Settings - Registry).

Properties Hive HKEY_CURRENT_USER Key path Control Panel\Desktop Value name Wallpaper Value type REG_SZ Value data \yourserver\Public\looknfeel\background.jpg

Obviously make sure to first check the event log to make sure your policies are being applied as this would be the first place to check.

share|improve this answer
add comment

Check the RDP settings. I seem to recall that by default RDP disables wallpaper to save on bandwidth/reduce latency.

share|improve this answer
    
Thats true, but I explicitly enabled Aero, background etc. As I can see the desktop background picture this seems to be an indicator for me that background is shown –  Heinrich Nov 3 '11 at 8:12
add comment

Login as the user in question that did not get the required desktop. Run RSOP to make sure they are issued the GPO in question. Make sure the GPO is enforced. Make sure other GPO's higher in the food chain are not enforcing a different policy for Desktops. Read through the information below.

When a Group Policy Object (GPO) is link enabled it means the settings in the Group Policy Object will be applied to the object (can be a Local System, Domain, Site and Organizational Unit) to which it has a link.

By default settings in Group Policy Objects (GPOs) get applied in the following order: Local system policies first, then policies on the Active Directory Domain level, then policies on the Active Directory Site level and then the policies for all the Organization Units the computer and user are members of, starting at the root of the domain. The settings that are last applied are the settings in effect.

When a Group Policy Object (GPO) is enforced it means the settings in the Group Policy Object on an Organization Unit (which is shown as a folder within the Active Directory Users and Computers MMC) cannot be overruled by a Group Policy Object (GPO) which is link enabled on an Organizational Unit below the Organizational Unit with the enforced Group Policy Object (GPO). In Active Directory Users and Computers MMC 'below' means it is a subfolder.

Here is a post about resolving this issue. Your "policies" path may be incorrect: check out the post here and be sure you have applied the hotfix.

Lastly, be sure the location of the files to be set as the wallpaper are on a server share that is accessible to everyone and NTFS permissions are correct.

share|improve this answer
    
Thanks for the extensive answer! As far as I see I have no Site GPOs and there are only two GPOs applied to the user: The Default Domain Policy which does not set any Wallpaper stuff or anything that could affect these settings and a second GPO which contains only the setting for the Wallpaper. I checked all the policies, but they are correct, I even enforced the wallpaper GPO but without success. What appears quite weird to me is the fact that after the first logon the logo is correct. (also see my edit) –  Heinrich Nov 3 '11 at 8:28
add comment
up vote 0 down vote accepted

I could finally find out what the problem is. Windows applies the settings I set through the registry and this is working fine. The problem is that on the Windows Server 2008 R2 clients the Theme will finally decide which wallpaper is set.

So everything I had to do was creating a custom theme and loading this theme for the users through GPO.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.