Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I must have done this a dozen times. I follow the instructions at http://help.github.com/mac-set-up-git/

Permission denied (publickey,keyboard-interactive).
fatal: The remote end hung up unexpectedly

I have double checked a valid email which is the same email I use on github. I also have set my profile up properly using:

$ git config --global user.name "Firstname Lastname"
$ git config --global user.email "your_email@youremail.com"

I also make sure that when I copy my key over that no newline or spaces are in the text.

I am pulling my hair on this one.

share|improve this question
    
Can you add the command you run while you try to clone as well? –  Kvisle Nov 3 '11 at 6:46
    
git clone git@accountname.beanstalkapp.com:/somefile.git (i have changed the name for accountname). Please note that the same command worked 2 days ago. I was messing around today in keychain ETC and since then nothing has worked. –  jini Nov 3 '11 at 6:54
1  
do you have keys? Are they uploaded to Github? Show results of executing ssh -T git@github.com or, even better with debug ssh -vT git@github.com –  Lazy Badger Nov 3 '11 at 8:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.