Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to Remote Control another user on a WTS 2008 server, I disconnect the other user and get a "Access denied" popup.

It's not a lack of permissions since I'm the Domain Admin. I think it has something with the W7 RDP client, but I haven't get any clue what to do about it.

Anyone else experiencing the same problems?

share|improve this question
    
Can you confirm whether you're using Server 2008, or Server 2008 R2? –  Nic Nov 27 '11 at 0:25
    
I'm using 2008 R2... –  Hornbech Dec 1 '11 at 13:30

2 Answers 2

There are a multitude of acknowledged bugs that pertain to this specific issue. I have yet to get it to succesfully work on anything other than R2 with a W7 client with no multimonitors, but check out the solutions listed below to see if they apply to your situation.

http://support.microsoft.com/kb/2523307 and http://support.microsoft.com/kb/2484290

share|improve this answer
    
oops... talk about a resurrection –  Mitch Aug 20 '12 at 23:06
    
No problem :) Found the hotfixes myself :) –  Hornbech Aug 22 '12 at 6:02

Have you configured the Terminal Server to allow remote control of sessions without prompting the user? This can be changed on the RDP-TCP object in Terminal Services Manager, or with Group Policy. If this isn't set, you won't get control until the user explicitly approves it.

Also good to know: starting with Server 2008 R2, Remote Desktop Services supports multiple-monitor connections. However, it's impossible to remote control a session that is using multiple monitors, so if you rely on remote control then you should disable multi-monitor support.

share|improve this answer
    
Yes I've set that option... To no avail :( –  Hornbech Dec 1 '11 at 13:30
    
Is the client using the Use all my monitors for the remote session feature? This prevents remote control from working. –  Nic Dec 1 '11 at 16:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.