Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Having a vtrak m310p unit, connected to a adaptec AIC79XX on a modern debian Squeeze.

On the Promise DAS, I've tried to create arrays and volumes of many sizes, but during boot the scan of the id's of the scsi card reveals nothing. I have made sure that:

  • The created volumes are associated with correct channel (channel 1)
  • All scsi targets I try to use are enabled (0-5)
  • The volumes have been mapped to a specific (enable) target.
  • Tried manual intitialization

Is there something I am missing? I haven't ever really experienced problems like this before, but I haven't worked much with SCSI either.

From what I see in dmesg;

[    1.229013] scsi2 : Adaptec AIC79XX PCI-X SCSI HBA DRIVER, Rev 3.0
[    1.229015]         <Adaptec 29320LPE PCIe Ultra320 SCSI adapter>
[    1.229016]         aic7901: Ultra320 Wide Channel A, SCSI Id=7, PCI-X 101-133MHz, 512 SCBs
[    1.486207] scsi target2:0:0: asynchronous
[    1.743239] scsi target2:0:1: asynchronous



After editing Termination from 'Automatic' to 'On', I get a lot of 'External bus reset has occurred' in the event log. Some site suggested that the particular adaptec controller wouldnt be happy with Linux and 320MB/s. Some 300 rows of error logged too:

[   21.816021] scsi 2:0:0:0: Attempting to queue an ABORT message:CDB: 0x12 0x0 0x0 0x0 0x24 0x0
[   21.816583] scsi2: At time of recovery, card was not paused
[   21.816592] >>>>>>>>>>>>>>>>>> Dump Card State Begins <<<<<<<<<<<<<<<<<
[   21.816593] scsi2: Dumping Card State at program address 0x1f Mode 0x11
[   21.816596] Card was paused
[   21.816600] INTSTAT[0x0] SELOID[0x0] SELID[0x0] 
[   21.816613] HS_MAILBOX[0x0] INTCTL[0x0] SEQINTSTAT[0x0] 
[   21.816636] SCSISIGI[0x0]:(P_DATAOUT) SCSIPHASE[0x0] 
[   21.816645] SCSIBUS[0x0] LASTPHASE[0x1]:(P_DATAOUT|P_BUSFREE) 
[   21.816656] SCSISEQ0[0x0] SCSISEQ1[0x12]:(ENAUTOATNP|ENRSELI) 
[   21.816665] SEQCTL0[0x0] SEQINTCTL[0x0] SEQ_FLAGS[0x0] 
[   21.816677] SEQ_FLAGS2[0x4]:(SELECTOUT_QFROZEN) 
[   21.816685] QFREEZE_COUNT[0x0] KERNEL_QFREEZE_COUNT[0x0] 
[   21.816697] MK_MESSAGE_SCB[0xff00] MK_MESSAGE_SCSIID[0xff] 
[   21.816705] SSTAT0[0x0] SSTAT1[0x0] SSTAT2[0x0] 
[   21.816733] LQISTAT0[0x0] LQISTAT1[0x0] LQISTAT2[0x0] 
[   21.816744] LQOSTAT0[0x0] LQOSTAT1[0x0] LQOSTAT2[0x0] 
[   21.816770] 
[   21.816771] SCB Count = 4 CMDS_PENDING = 1 LASTSCB 0xffff CURRSCB 0x3 NEXTSCB 0x0
[   21.816781] qinstart = 1 qinfifonext = 1
[   21.816782] QINFIFO:
[   21.816784] WAITING_TID_QUEUES:
[   21.816800] Pending list:
[   21.816804]   3 FIFO_USE[0x0] SCB_CONTROL[0x50]:(MK_MESSAGE|DISCENB) 
[   21.816815] SCB_SCSIID[0x7] 
[   21.816818] Total 1
[   21.816819] Kernel Free SCB list: 2 1 0 
[   21.816824] Sequencer Complete DMA-inprog list: 
[   21.816831] Sequencer Complete list: 
[   21.816837] Sequencer DMA-Up and Complete list: 
[   21.816843] Sequencer On QFreeze and Complete list: 

SOLVED: As it turns out, the VTRAK JBOD had target 7 enabled so it was on collision course with the controller itself.

on the VTRAK "target 7" was enabled, which is the same id the controller uses, so I disabled the target ID on the VTRAK but one could of course change the ID on the controller card as well. (although may not be recommended as target 7 is default for controllers).

share|improve this question
I used to think Adaptec was the best controller card brand. Unfortunately,I spent many days trying to figure out why my file server kept crashing after a year of good use with a Promise VTRAK array. It turned out that the Adaptec driver couldn't handle the load at that point. Once you get this figured out, do yourself a favor and switch to an LSI controller card. –  Jeff Strunk Nov 3 '11 at 18:24
Have you tried getting it to work with just one volume first? I'm rusty on setting this up, but I recall that all the volumes I set up were automatically detected. Just to make sure, do you have a terminator on the vtrak? –  Jeff Strunk Nov 3 '11 at 18:29
@3molo: you should post the ultimate solution as an answer and accept it, it may help someone someday. –  ThatGraemeGuy Nov 7 '11 at 15:11
I thought it was kind of self-explanatory. Added a better description of the solution. –  3molo Nov 8 '11 at 8:22
No not in the question. Add a separate answer (and accept it) so it's marked closed for good. –  faker Nov 8 '11 at 8:28
show 1 more comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.