Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just wanted to see if its possible or even Necessary to use application deployment for a .Net application under terminal server.

im aware that applications are installed on the server and the users then run them in this fashion, however the applicaiton is a home brewed one from our company and seems to still need an initial installation when the user runs it for the first time on there "desktop" session.

Its bundled as an MSI installer from Visual Studio so i have no issues using this if needed, im just not sure the best method of installing this application or the problems associtated with installing on each client "session" as it goes along vs deploying the app during user login.

Is it a better idea to uninstall the application from the TS, and use GPO to deploy it to the client as they log in??

any suggestions on how this can be acomplished would be appreciated.

Kris

share|improve this question

1 Answer 1

Have you tried installing it in the recommended fashion for installing TS apps ? You need to either start the installer through the "install" buttong of the add/remove contraol panel applet or run the "change user /install" command-line first (and run "change user /execute" once you're done).

share|improve this answer
    
I have not tried the Install from Add Remove programs window yet, I did however do the Change user /install and then /execute after the installer was finished. I will have ago at uninstalling the application from the TS and re-installing it from the Add/Remove Programs window to see if it makes a difference. Failing this idea, if the program still behaves as it does presently, am i correct in thinking this is likely to be the way the installer is configured ? –  Kristiaan Nov 3 '11 at 10:17
    
Just realised that Windows 2008 does not have the install button within add remove programs in the control panel anymore so im not able to-do this. @Stephane –  Kristiaan Nov 3 '11 at 14:35
    
You haven't specified what OS you where using. However, going though the "install a program" button did, basically, exactly the same thing as using "change user /install". One thing you might want to do, however, is to start the application at least once before calling "change user /execute" as it might catch additional configuration steps performed on first run. If this fails, however, I suggest you go to the devs and ask them what the application does on first startup: maybe it can be duplicated without too much hassle. –  Stephane Nov 3 '11 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.