Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am attempting to utilize NFS4 ACL's in an environment already utilizing POSIX ACL's. I've found a handful of sites on the internet that explain some technical details about NFS4 ACL's and how they're created, but the tools seem to fail for me when I try to execute them.

Does anyone have a good resource/tutorial to explain how to setup NFS4 ACLs?

When I try to change the ACL set from the server:

[root@ny-bar01 foo_server]# nfs4_setfacl -e /nfs/obfuscate/
Operation to request attribute not supported.
Failed to instantiate ACL.

When I try to change the ACL set from the client:

[root@ny-baz02 foo_client]# nfs4_setfacl -R -e .
Failed setxattr operation: Operation not permitted
An error occurred during recursive file tree walk.
share|improve this question
Do you have no_root_squash set for your nfs exports? That may cause your operation not permitted error. – Jeff Strunk Nov 3 '11 at 18:14
Nope, root squash is enabled – Peter Grace Nov 4 '11 at 12:47
Now that I reread my comment, I should've defined "that" better. Try using no_root_squash or set the ACL as a non-root user. – Jeff Strunk Nov 4 '11 at 17:00
Thank you soo much... It really worked.. I had missed no_root_squase while exporting.. It worked finally ,, Thanks :) – user147586 Nov 29 '12 at 13:40
up vote 1 down vote accepted

For the record, we found out that ext4 does not natively support NFS ACL's. There are a few filesystems with experimental NFS4 ACL support, but, experimental is not the word I want attached to my production environment.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.