Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I migrated awstats from one server to another, and I copied the old stats and configuration. I had to change apache log directory but it seems it is working: http://permaculture.org.au/awstats/awstats.pl

The issue is that icons are missing and graphics do not have colours. The line in apache2 config

Alias /awstats-icon/ "/usr/share/awstats/icon/"

is okay since there are the icons in that directory:

root@server:/etc/awstats# ls -l /usr/share/awstats/icon/ total 36 drwxr-xr-x 2 root root 4096 2011-11-03 13:34 browser drwxr-xr-x 2 root root 4096 2011-11-03 13:34 clock drwxr-xr-x 2 root root 4096 2011-11-03 13:34 cpu drwxr-xr-x 2 root root 12288 2011-11-03 13:34 flags drwxr-xr-x 2 root root 4096 2011-11-03 13:34 mime drwxr-xr-x 2 root root 4096 2011-11-03 13:34 os drwxr-xr-x 2 root root 4096 2011-11-03 13:34 other

last issue is that when I run awstats from the shell the script hangs here:

root@server:/etc/awstats# /usr/lib/cgi-bin/awstats.pl -config=awstats.permaculture.org.au.conf -update Create/Update database for config "/etc/awstats/awstats.conf" by AWStats version 6.9 (build 1.925) From data in log file "/var/log/apache2/access.log"... Phase 1 : First bypass old records, searching new record... Searching new records from beginning of log file... Phase 2 : Now process new records (Flush history on disk after 20000 hosts)... Reverse DNS lookup for ::1 not available without ipv6 plugin enabled.

share|improve this question
add comment

3 Answers 3

We have alias in apache config file:

Alias /awicon /usr/share/awstats/icon
share|improve this answer
add comment

If the icons are missing on the web page. Check with your access.log for it would show you the images that are not found as 404 and you would know where is the webpage searching for the icons in and configure your alias as accordingly.

Secondly, disable IPv6 if you are not running/using it. ::1 is the ipv6 address for your localhost. Also you might be missing a few perl modules see here for more info.

share|improve this answer
add comment

I have symlinked the icons from the configured virtual host root directory to the real directory where they were stored.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.