Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've a domain controller running Windows 2003 fully patched. Whenever I login to remote desktop it'll login fine within a few seconds, I can then close the window or logout and then go back to it and it once again logs in fine. If however I leave it idle for ages and my session is automatically locked, I then close the window and reopen it when I need it again later, it takes 30-60 seconds (I've not actually timed it) for me to login as it just hangs with the grey desktop background.

Any idea to what could be causing this or how I could debug it?

Thanks

share|improve this question
    
What kind of connection do you have been you and the server? –  Joseph Jun 28 '09 at 0:44
    
A solid LAN. I don't believe this is the issue either as authentication is fine so long as I logout prior or close the window rather than letting it idle. –  Adam Gibbins Jun 28 '09 at 10:16

2 Answers 2

up vote 1 down vote accepted

I think the best bet is to get some more insight in what is happening.

I would suggest the following; On the client:

  • Do a TCP dump (using whireshark for example) to see what is happening when you try to reconnect

On the server:

  • Do a TCP dump and compare it with the client (this will rule out or point out any network problems).

  • Use regmon and filemon on the console when trying to connect (this will point out missing files or files which are exclusively locked by another process).

  • Use processexplorer from the console and try to see if a process is consuming more resources then normally necessary.

Currently my crystal ball tells me that it could well be a file being locked by a process which is needed when you try to reconnect to the server.

share|improve this answer
    
The client is actually a linux machine connecting via rdesktop, but I get this issue even when using an XP machine on the domain. –  Adam Gibbins Jun 28 '09 at 10:15
  1. What are the resources being shared between the local machine and the one you're rdp'ing? May be you can try to disable all resources from being shared and give it a try?
  2. Is this a local account or a domain account you are using on the Windows 2003 box? If its a domain account, can you try to do this with a local account and see if it still hangs? This way, we can isolate if its an issue with userenv or with the machine it.
  3. Do you see any events logged in the event viewer on the 2003 box right after you unlock the screen?
share|improve this answer
    
1. None are shared. 2. Have tried with 2 domain users and a local, same problem. 3. Nope –  Adam Gibbins Jun 28 '09 at 22:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.