Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a MS SQL2008 server running a root instance and a named instances.



When I connected to SQL001\Pilgrim I can set-up a link to the default instance SQL001\. no problem, but when I connect to the Default Instance SQL001\. and try to add a link to the named instance SLQ001\Pilgrim I get the error below.

This was working before I rebooted the server nearly a month ago but all services are running. I have tried restarting them.

The server in Windows 2008 R2 64bit and MSSQL is 2008. I am using Microsoft SQL Server Management Studio on the server itself and the firewall is off.

The web applications and clients that use both instances are working perfectly.

SQL Error: Encryption not supported on the client

share|improve this question
To clarify - You CAN connect locally through SSMS on the server itself, right? The issue is that you can't create a linked server on that server to an instance on the same server? Can you go the other direction with the linked server? – Mike Walsh Nov 4 '11 at 16:19
Sorry for delay in replying, been ill. Yes I can connect directly to either instance through SSMS. When connected to the named instance I CAN create a linked server connection to the default instance. When connected to the default instance I CAN'T create a linked server connection to the named instance. – Yeodave Nov 9 '11 at 9:35
Can you connect to the named instance via SSMS remotely from your laptop or another machine? – Mike Walsh Nov 9 '11 at 16:29
Yes, it is just the linked server connection from the default instance that is not working. – Yeodave Nov 11 '11 at 11:13
up vote 2 down vote accepted

I would start out by verifying:

A.) Ensure Named Pipes and TCP/IP are both enabled for the named instance. (SQL Server Configuration Manager --> Server Network Config --> Protocols --> Verify TCP/IP, Named Pipes are enabled

B.) SQL Server Browser service is enabled and running

share|improve this answer
Named Pipes were disabled on the default instance so I am turning them on. Says service needs to be restarted so I will have to do that out of hours and let you know. Ta. – Yeodave Nov 11 '11 at 11:40
Pretty sure that's your issue. Sounds good, looking forward to results after restart. – Mike Walsh Nov 11 '11 at 12:22
Thanks Mike, that worked. Sorry for delay in getting back to you. – Yeodave Dec 16 '11 at 16:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.