Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to have Tomcat 7 listen on 2 different ports for HTTP requests (the 2nd port makes webapps think it's receiving https requests because that's what's happening on the load balancer). But the 2nd port doesn't work, it just hangs when you try to request a URL from it:

<Connector port="80" protocol="HTTP/1.1" URIEncoding="UTF-8" compression="2048"
           connectionTimeout="20000" 
           redirectPort="443" />
<Connector port="480" protocol="HTTP/1.1" URIEncoding="UTF-8" compression="2048" 
           connectionTimeout="20000"
           redirectPort="443"
           scheme="https" secure="true"/>

Why won't port 480 listen to http requests?

catalina.out shows no issues whatsoever and tomcat is technically listening to port 480:

# tail catalina.out
Nov 4, 2011 4:09:48 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-80
Nov 4, 2011 4:09:48 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-480

# netstat -nlp | grep ":80\|:480"
tcp        0      0 :::480                      :::*                        LISTEN      30046/java          
tcp        0      0 ::ffff:127.0.0.1:8005       :::*                        LISTEN      30046/java          
tcp        0      0 :::8009                     :::*                        LISTEN      30046/java          
tcp        0      0 :::80                       :::*                        LISTEN      30046/java          
share|improve this question
    
netstat -nlp | grep :480? Also take a look at the catalina.out. –  quanta Nov 5 '11 at 2:40
    
I should've mentioned catalina.out showed no warnings or errors whatsoever –  apptree Nov 5 '11 at 4:53
    
I updated the question with catalina.out and netstat showing no issues (that I can recognize) –  apptree Nov 5 '11 at 5:16

1 Answer 1

up vote 0 down vote accepted

The issue was with my firewall settings. I was blocking port 480 :(. I feel less than smart...

share|improve this answer
    
Glad you've resolved the issue. Please be sure to mark your answer as "accepted" when you are able. –  jscott Jul 16 '12 at 14:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.