Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I created a login name in SQL Server 2008 by

  1. right click on security then new->login
  2. specify a name , password and server map.
  3. Right-click on SQL Server instance at root of Object Explorer, click on Properties
  4. Select Security from the left pane.
  5. Select the SQL Server and Windows Authentication mode radio button, and click OK.
  6. Open up Services and restart the SQL Service (SQLEXPRESS) Windows service.

but it has following error:

login failed for user gggggggg (microsoft sqlserver error 18456)

what is the problem?

share|improve this question

migrated from stackoverflow.com Nov 5 '11 at 11:04

This question came from our site for professional and enthusiast programmers.

    
a) did you give your "login" access to any of the databases in your server?? b) is this a "remote" SQL SErver Express (on another machine) - if so, is "remote login" enabled (it's OFF by default) ?? –  marc_s Nov 5 '11 at 9:46
    
how can i enable 'remote login'? –  mehdi Nov 5 '11 at 9:49
    
See: datamasker.com/SSE2005_NetworkCfg.htm or thousands of other articles on that topic - Google is your friend ! –  marc_s Nov 5 '11 at 9:50

1 Answer 1

If the userId really exist, might be disabled on the server. Password might have expired and probably several other reasons ...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.