Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My server runs PHP 5.3.8 and has this issue of not receiving emails that are sent from accounts located not in my server.

For example, if I submit a message through a contact form on my blog 'blog123.com' to an email like 'astroman@blog123.com' the email is received.

However if I send and email from Gmail to 'astroman@blog123.com', no email is received.

I can send messages from accounts on this server to any destination, no problem.

I've checked logs at

/usr/local/psa/var/log/maillog

and there are no errors, but here and there I see this

Nov  5 18:51:53 p2457330 postfix/smtp[3609]: certificate verification failed for gmail-smtp-in.l.google.com: num=27:certificate not trusted

not sure if its related to the problem.

Any ideas how to solve this?

Here is the postconf -n

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases, hash:/var/spool/postfix/plesk/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = all
inet_protocols = ipv4
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
message_size_limit = 10240000
mydestination = localhost.$mydomain, localhost, localhost.localdomain
myhostname = excample.com
mynetworks = 127.0.0.0/8, 10.2.0.157/32
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_send_xforward_command = yes
smtp_tls_security_level = may
smtp_use_tls = no
smtpd_authorized_xforward_hosts = 127.0.0.0/8
smtpd_client_restrictions = 
smtpd_proxy_timeout = 3600s
smtpd_recipient_restrictions = permit_mynetworks, check_client_access pcre:/var/spool/postfix/plesk/no_relay.re, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sender_restrictions = check_sender_access hash:/var/spool/postfix/plesk/blacklists, permit_sasl_authenticated, check_client_access pcre:/var/spool/postfix/plesk/non_auth.re
smtpd_timeout = 3600s
smtpd_tls_cert_file = /etc/postfix/postfix_default.pem
smtpd_tls_key_file = $smtpd_tls_cert_file
smtpd_tls_security_level = may
smtpd_use_tls = yes
transport_maps = hash:/var/spool/postfix/plesk/transport
unknown_local_recipient_reject_code = 550
virtual_alias_maps = $virtual_maps, hash:/var/spool/postfix/plesk/virtual
virtual_gid_maps = static:31
virtual_mailbox_base = /var/qmail/mailnames
virtual_mailbox_domains = $virtual_mailbox_maps, hash:/var/spool/postfix/plesk/virtual_domains
virtual_mailbox_maps = hash:/var/spool/postfix/plesk/vmailbox
virtual_transport = plesk_virtual
virtual_uid_maps = static:110

Netstat info (FYI my IP "29.5.29.3" is a dummy for security reasons)

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
tcp        0      0 0.0.0.0:993                 0.0.0.0:*                   LISTEN      30793/couriertcpd   
tcp        0      0 0.0.0.0:225                 0.0.0.0:*                   LISTEN      2391/xinetd         
tcp        0      0 0.0.0.0:995                 0.0.0.0:*                   LISTEN      30810/couriertcpd   
tcp        0      0 127.0.0.1:10025             0.0.0.0:*                   LISTEN      2619/master         
tcp        0      0 127.0.0.1:10026             0.0.0.0:*                   LISTEN      2619/master         
tcp        0      0 0.0.0.0:106                 0.0.0.0:*                   LISTEN      2391/xinetd         
tcp        0      0 0.0.0.0:2123                0.0.0.0:*                   LISTEN      11744/dsmcad        
tcp        0      0 127.0.0.1:10027             0.0.0.0:*                   LISTEN      2619/master         
tcp        0      0 0.0.0.0:1581                0.0.0.0:*                   LISTEN      11744/dsmcad        
tcp        0      0 0.0.0.0:110                 0.0.0.0:*                   LISTEN      30801/couriertcpd   
tcp        0      0 0.0.0.0:143                 0.0.0.0:*                   LISTEN      30783/couriertcpd   
tcp        0      0 0.0.0.0:8880                0.0.0.0:*                   LISTEN      18708/sw-cp-serverd 
tcp        0      0 127.0.0.1:10001             0.0.0.0:*                   LISTEN      18708/sw-cp-serverd 
tcp        0      0 0.0.0.0:465                 0.0.0.0:*                   LISTEN      2619/master         
tcp        0      0 29.5.29.3:53           0.0.0.0:*                   LISTEN      18417/named         
tcp        0      0 127.0.0.1:53                0.0.0.0:*                   LISTEN      18417/named         
tcp        0      0 0.0.0.0:21                  0.0.0.0:*                   LISTEN      2391/xinetd         
tcp        0      0 127.0.0.1:3000              0.0.0.0:*                   LISTEN      1288/drwebd.real    
tcp        0      0 127.0.0.1:953               0.0.0.0:*                   LISTEN      18417/named         
tcp        0      0 0.0.0.0:25                  0.0.0.0:*                   LISTEN      2619/master         
tcp        0      0 0.0.0.0:8443                0.0.0.0:*                   LISTEN      18708/sw-cp-serverd 
tcp        0      0 :::3306                     :::*                        LISTEN      20884/mysqld        
tcp        0      0 :::80                       :::*                        LISTEN      841/httpd           
tcp        0      0 :::22                       :::*                        LISTEN      11198/sshd          
tcp        0      0 :::443                      :::*                        LISTEN      841/httpd           
udp        0      0 29.5.29.3:53           0.0.0.0:*                               18417/named         
udp        0      0 127.0.0.1:53                0.0.0.0:*                               18417/named         
udp        0      0 29.5.29.3:123          0.0.0.0:*                               2407/ntpd           
udp        0      0 127.0.0.1:123               0.0.0.0:*                               2407/ntpd           
udp        0      0 0.0.0.0:123                 0.0.0.0:*                               2407/ntpd           
udp        0      0 fe80::230:48ff:fefa:123     :::*                                    2407/ntpd           
udp        0      0 ::1:123                     :::*                                    2407/ntpd           
udp        0      0 :::123                      :::*                                    2407/ntpd
share|improve this question
    
Could you add the postfix configuration? (postconf -n) –  Bart De Vos Nov 5 '11 at 23:16
    
sorry for the delay @bart - the postfix is in OP –  torr Nov 6 '11 at 0:42

2 Answers 2

A couple of things could be wrong here:

Frist of all, you should check if postfix is listening on the right interface (netstat -tulpn). But I think it isn't listening to any WAN-addresses since this is in the config file:

mynetworks = 127.0.0.0/8, 10.2.0.157/32

(I really hope your server is not in a LAN) So, add your WAN-IP in this list. I see you have plesk installed, so maybe you could configure this in plesk somewhere but I wouldn't know since I know nothing about Plesk.

Next, check your MX-settings for your domain. Is it pointing towards your server?

share|improve this answer
    
thx @bart - posted the netstat info in case that confirms what you're thinking - let me kow - thx for helping –  torr Nov 6 '11 at 14:01
    
problem was the firewall, see above - sorry for the confusion, and thx for helping –  torr Nov 6 '11 at 15:31
up vote 0 down vote accepted

This was an issue caused by my ISP configuring the firewall way too restrictive. After calling in and going over the possibilities, they figured out the firewall problem and now things work as expected.

share|improve this answer
    
Would you please accept your answer. –  mailq Nov 8 '11 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.