Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I added another 8TB to my 20TB array and tried to expand it with xfs_growfs, no joy and no idea why it is failing. Much googleing has provided some answers but nothing that has worked.

I am at my wits end here, I have been working on this off and on for a couple weeks now and there seems to be roadblocks every step of the way. One of the google links mentioned that there was a problem growing to the max size and I needed to grow to just 55 blocks under the full size of the disk, that didn't work, others mention that the OS must be 64 bit, already established that to be the case...

ANY help would be greatly appreciated here, I am trying to avoid setting up another array and copying the data off, reformatting and copying back. Thank you!

OS: CentOS 5.6 x64 + an Areca 1880

[root@server ~]# xfs_growfs /mnt/array/
meta-data=/dev/sdb1              isize=256    agcount=32, agsize=167846623 blks
         =                       sectsz=512   attr=1
data     =                       bsize=4096   blocks=5371091936, imaxpct=25
         =                       sunit=0      swidth=0 blks, unwritten=1
naming   =version 2              bsize=4096
log      =internal               bsize=4096   blocks=32768, version=1
         =                       sectsz=512   sunit=0 blks, lazy-count=0
realtime =none                   extsz=4096   blocks=0, rtextents=0
xfs_growfs: XFS_IOC_FSGROWFSDATA xfsctl failed: Invalid argument

J

share|improve this question

2 Answers 2

At some point, there was a problem with xfs_growfs on 64bit kernels. Maybe this is the case here?

You can try this with booting into some 32bit rescue or live system, mount the array and start xfs_growfs.

Edit: I assume you not only expanded the drive on the controller, but also expanded the size of the partition with fdisk or something similar. If not, expanding can not work as xfs_growfs doesn't see the added space. I am sorry if this sounds obvious, just wanted to be sure ;)

share|improve this answer

Can you show your fdisk -l output? Did you make the partition table change, save it and reboot (or run partprobe) before attempting your xfs_growfs?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.