Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have disabled selinux with:

setenforce 0 
selinux=disabled

in /etc/selinux/config Does anyone knows if i have to label or chcon any dir to solve that error:

error [error] [client 127.0.0.1] (13)Permission denied: access to /index.php denied  

I'm running centOS6.

share|improve this question
add comment

migrated from stackoverflow.com Nov 7 '11 at 10:27

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 3 down vote accepted

Check file and directory permissions of this file and all parent directories. They need to typically be world readable.

Often times this happens if you put some files in a home directory, but the home dir is still at it's default of 700. Run chmod 755 /home/you to correct that.

share|improve this answer
    
thanks a lot :) –  user846226 Aug 5 '11 at 17:06
add comment

The code below might help you. Had the same problem with SELinux:

chcon -Rv --type=httpd_sys_content_t /you_virtual_host_direcory
share|improve this answer
    
this won't help as SELinux IS disabled –  alexus Jan 16 '13 at 17:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.