Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a mail server that periodically connects to the Internet via modem dialup. And before I was able to send emails with attachments of 300kb and 500kb in just only 1 or 2 minutes. I have not made ​​any change in Postfix and now it takes longer than normal to flush the Postfix queue. Sometimes it takes more than 10 minutes to deliver an email of just 300kb. If this mail is in queue with others mails containing only text, then the rest will be delivered normally while the one containing an attachment of 300kb is delayed more than usual. Previously this was not happening and all the emails have been sent very quickly.

Any suggestion of what is going on here? Can this be caused by a very large Postfix maillog file that needs to be rotated, or reconfiguration the master.cf?

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

Nothing special. It is very likely that your connection bandwidth is lower than you expect. It depends on the modem speed and connection speed. But sending that big messages via modem takes that long. It is not unusual. Even if you also have other network traffic going over the line in parallel.

share|improve this answer
    
i know that the conection bandwidth is quite slow, but in just weeks ago this mails of 300kb was sended in just 2 minutes, now they take around 10 or 15 minutes to go out, the only other network traffic that is going over is fetchmail cheking for new mail in yahoo, gmail and msn but anyway if i stop working fetchmail just leave postfix work alone it still delays to out the messages with attachments. This can be happening cause of the maillog file have a larger size? it can have sense to think in this? –  nerdhacker Nov 7 '11 at 15:54
    
@nerdhacker The logfile is definitively not the cause. –  mailq Nov 7 '11 at 15:59
add comment

The small ones get delivered but the large one takes weeks? That sounds like it is having to have multiple attempts before it successfully maintains a connection long enough to deliver the whole email. If it doesn't send the entire email in one go (or if it doesn't get a response from the mail server that it was received correctly) then Postfix puts it back in the deferred queue and tries again next time.

Check your mail log and see if the large email is actually having several attempts at sending.

You should also be able to see the reason it failed in the mail queue by running the mailq command.

If this is the case, it's either a flaky connection at your end or at the recipient's end.

share|improve this answer
    
The large ones gets delivered, but in more minutes than before, like i said, days before it was able to send a mail with an 300kb attachment in just 2 minutes and now it takes more long to send it, sometimes geting up to more that 10 minutes, i am using the smtp.gmail.com to relay the email and everything is correct under there. i see in the maillog the queue active for the mail id that correspond to the mail with attachment, but i have too wait too long to see the response from smtp.google.com that confirm it was sent and of course finally removed from postfix queue. –  nerdhacker Nov 7 '11 at 17:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.