Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i have got a nasty problem:

For web developing i have a:

  • oracle virtualbox
  • xubuntu 10.04 lts in a
  • xampp for Linux 1.7.3a

Configured with several virtual hosts for offline-testing my websites. For developing / designing E-Mails i need an e-mail server. I want simply to send mails from my websites and see them in an e-mail - client in virtualbox. no sending e-mails to outside the virtualbox.

So i installed postfix.

But i simply cant get it to work. Now i test with a simple joomla E-Mail Form (phpmailer). But it cant connect to my smtp. Logfiles say:

mail.info:

Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: warning: ::1: address not listed for hostname localhost
Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: connect from unknown[::1]
Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: lost connection after RSET from unknown[::1]
Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: disconnect from unknown[::1]
Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: warning: ::1: address not listed for hostname localhost
Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: connect from unknown[::1]
Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: lost connection after RSET from unknown[::1]
Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: disconnect from unknown[::1]

mail.warn:

Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: warning: ::1: address not listed for hostname localhost
Nov  8 19:24:51 joe-desktop postfix/smtpd[4221]: warning: ::1: address not listed for hostname localhost

postfix doesnt know ::1? but it should. here my configuration files:

hosts:

127.0.0.1 localhost
127.0.0.1 test1
127.0.0.1 test2
127.0.1.1 joe-desktop
127.0.0.1 xampp
127.0.0.1 test3
127.0.0.1 test4

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

And in main.cf:

mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mydestination = joe-desktop, localhost.localdomain, localhost

I installed webmin to configure postfix. in webmin i can send & receive mails. so postfix should run.

I'm searching now for hours, i hope someone can help me. But I must admit i am really not a linux pro. I hope someone can help me. Bye, Mojo

share|improve this question

closed as off-topic by MDMarra, Falcon Momot, Dennis Kaarsemaker, cole, freiheit Jan 4 at 0:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – MDMarra, Falcon Momot, Dennis Kaarsemaker, cole, freiheit
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Personally, I would go with exim4. The configuration system will get you a working setup by default, and a lot of basic config can be done by running dpkg-reconfigure exim4-config. Postfix theoretically should be just as easy, but I am not familiar with it. –  Zoredache Nov 8 '11 at 23:31
add comment

1 Answer

Thank you for your comment. I solved the problem, i turned off authentification and now sending to joe@localhost works.

One further question.

If I send i.e. to "tester@mydomain.de" postfix says in log:

Recipient address rejected: mydomain.de

ist it possible that smtp accepts E-Mails to all receipients / all domains and relays them to joe@localhost?

Does s.o. know how to configure that?

The system runs in a virtualbox without internet-connection. so spam is no problem.

Bye, Mojo

share|improve this answer
    
Answers are not designed to ask questions. Nobody will answer. –  mailq Nov 9 '11 at 14:36
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.