Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently performed a P2V on an old OEM XP installation.

This required running an in place install to convert from an OEM to a VLK. On completion I was unable to connect to remote desktop. netstat -ano | find "3389" returns nothing.

I tried axing and the [HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server] keys and importing from a known good source. This resulted in the service listening on 3389 but failing with "an error occurred while the connection was being established".

As far as I can tell the only difference between these two sets of registry keys are the color depth, a few printers and a VIDEO subkey:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\VIDEO\disc] "VgaCompatible"="\Device\Video0" "\Device\Video0"="\REGISTRY\Machine\System\CurrentControlSet\Services\TSDDD\Device0"

I also tried a frequently referenced KB article and devcon. No change.

devcon.exe -r install %windir%\inf\machine.inf root\rdpdr

I'm at a loss as to a solution to this issue.

EDIT - I'm sure that the necessary service is running and that the system is set up to allow remote access.

share|improve this question
add comment

2 Answers

Are you sure that the machine is setup for RDP still? Might just need to disable then enable RDP. Is the RDP service running?

share|improve this answer
    
Positive - I have group policy in place for those items. –  Tim Brigham Nov 8 '11 at 22:15
add comment
up vote 0 down vote accepted

I came up with a working solution for this issue. In the end there were several points that needed to be addressed.

1: The OEM license key, addressed by an in place repair.

2: Ghost devices. The P2V did not remove all the old hardware references included by the OS. To resolve I used a third devcon party script to remove all the extraneous entries.

3: A "Terminal Server Device Redirector" device was showing as not having the proper drivers installed. This was the result of the P2V. Resolved by removing the device.

4: Recreate the TS devices with devcon: devcon.exe -r install %windir%\inf\machine.inf root\rdpdr

5: Terminal Services not was still not functioning, not listening at all on port 3389 (via netstat -ano). To resolve I exported the registry keys from another VM with the same OS, SP and patch level and imported into the trouble VM.

Several sites indicated that a specific key \Device\Video0 is all that needs to be set. I found this not to be the case in my environment. Only after executing these in the exact order listed did I achieve the desired results.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.