Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed Oracle 9i HTTP Server together with the database. After restarting the PC, even though i restarted the IIS and stopped the Oracle HTTP Server. When I go to http://localhost/ The starting page is already the Oracle HTTP Server index page. Also when I look at the port that inetinfo.exe is listening to, it no longer listens to port 80 and the SSL port 443, even if i restart the IIS and World Wide Web Publishing service.

Any idea what setting did oracle changed when I installed oracle 9i?

The executable associated with the OracleOraHome90HTTPServer is C:\oracle\ora90\Apache\Apache\Apache.exe

I already checked the tasklist and Apache is really not running. But there is no process listening to port 80 still even if the IIS restarts successfully. Any ideas how to fix this?

share|improve this question

3 Answers 3

There should be something listening on port :80 if you are able to pull http://localhost. Try to check again what process listens there, most probably Oracle server was started again.

share|improve this answer

First, use netstat to verify that nothing is listening on port 80:

netstat -an | find ":80 " | find "LISTENING"

Then check what port and IP IIS is listening on. if memory serves, you can see that by right-clicking on the default web site node in IIS manager and check the properties.

share|improve this answer
    
I did use netstat and there is no application (either Oracle HTTP Server or inetinfo.exe) listening to the port. Must be somesort of cache. Even If I try to do Control Click the start page of Oracle HTTP Server shows but if you try to click any button like Examples they dont open the page. –  Nassign Nov 10 '11 at 8:11
    
Did you try my second suggestion, then ? –  Stephane Nov 10 '11 at 10:16
    
Yes Stephane, it was set to port 80. I restarted the PC, the Oracle cache was gone. It must be the IE cache but still the netinfo.exe does not listen to port 80. –  Nassign Nov 14 '11 at 0:42

I think I already know the cause. I looked at the the remaining services installed by Oracle 9i. [OracleOraHome90Agent, OracleOraHome90TNSListener, OracleServiceORCL] I started stopping them one by one and restarting IIS after each service is stopped. The IIS finally worked when I stopped the OracleServiceORCL service. I guess the database needs to be stopped too. Which is weird, in my initial guess I should only stop the OracleOraHome90HTTPServer service.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.