Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to get postfix (installed from blastwave) working on a Solaris 10 server, but only root is allowed to send mail. The problem appears to be permission related with postdrop.

postdrop: warning: mail_queue_enter: create file maildrop/905318.27416: Permission denied

I've checked that /var/opt/csw/spool/postfix/maildrop and /var/opt/csw/spool/postfix/public are both in the 'postdrop' group. main.cf contains setgid_group = postdrop.

ppriv on postdrop as non-root user reports:

postdrop[27336]: missing privilege "file_dac_write" (euid = 103, syscall = 5) needed at ufs_iaccess+0x110

I'm at a loss as to what to do next. I'm don't have much experience with Solaris; I use Linux daily. Any suggestions?

share|improve this question
    
Solaris uses RBAC (Role Based Access Control) which is similar to SELinux and AppArmor on Linux. Although you have already solved this problem, knowing this may help you in the future if you choose to stick with Solaris. –  Ladadadada Nov 16 '11 at 15:07
    
Thanks, @Ladadadada. The links you provided were quite enlightening. –  Zayne Nov 16 '11 at 20:53

2 Answers 2

up vote 0 down vote accepted

Have you tried postfix from OpenCSW? There's a newer version available (2.8.6 instead of 2.7.1), and this issue might have been addressed there.

share|improve this answer
    
Thanks! Migrated to OpenCSW and it now works properly. –  Zayne Nov 15 '11 at 19:21

The user with the id 103 (see your /etc/passwd for correspondig user) has not the right to write to the Postfix queue directory. You get the queue directory path with the command postconf queue_directory.

share|improve this answer
    
I understand that, but it isn't obvious as to why. In this case, the queue_directory is /var/opt/csw/spool/postfix, which is owned by root but is in the group postdrop. Standard configuration according to all the postfix documentation I've seen. –  Zayne Nov 10 '11 at 13:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.