Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed 2 versions of wordpress but none of them works :

It just gives me :

[Thu Nov 10 09:58:13 2011] [error] [client ] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 15184141552 bytes) in Unknown on line 0, referer: http://weareelsewhere.com/?p=1
[Thu Nov 10 09:58:19 2011] [error] [client ] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 15219759344 bytes) in Unknown on line 0, referer: http://weareelsewhere.com/
[Thu Nov 10 10:03:22 2011] [error] [client ] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 15290797552 bytes) in Unknown on line 0, referer: http://weareelsewhere.com/
[Thu Nov 10 10:03:59 2011] [error] [client ] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 16990008560 bytes) in Unknown on line 0, referer: http://weareelsewhere.com/wp-admin/profile.php

I've got a 8Gb memory server. So the problem is not the 2Gb limit for php. I Run under Debian with PHP

PHP 5.3.3-7+squeeze3 with Suhosin-Patch (cli) (built: Jun 28 2011 08:24:40) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH

Each time i try to navigate through the admin panel, it crashes, and downloads the page i want to reach (an empty .php file).

Where does it comes from ?

Thanks.

EDIT

<VirtualHost *:80>
       ServerAdmin webmaster@localhost
        ServerName weareelsewhere.com

        DocumentRoot /var/www/nicolas

        CustomLog /var/log/apache2/access-nico.com.log combined
        ErrorLog /var/log/apache2/error-nico.com.log
        ServerSignature Off
  <Directory "/var/www/nicolas">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
  </Directory>

</VirtualHost>
share|improve this question
2  
this sounds like a memory leak (tried to allocate 1.5GB?), it could be generated by a bad php include or an internal redirect loop.. are you using a fcgi backend? –  sysfault Nov 10 '11 at 10:00
    
No, all i did is to setup a vhost, to setup the wp-config and then follow the setup instruction. See my edit for vhost. This is my dedicated server. No cpanel or other crap installed on it. –  Tristan Nov 10 '11 at 10:10
    
well, give the man what he needs, memory_limit=-1, suhosin.memory_limit=0 in php.ini, remove any .htaccess configured php memory limits, if any. see what happens. I suppose youre running apache+mod_php. –  sysfault Nov 10 '11 at 10:15
    
err, memory_limit=8192M, suhosin.memory_limit=8192M, safe_mode=Off. no idea what could require so much memory but give it a try, see if wp eats it all –  sysfault Nov 10 '11 at 10:21
    
Same effect. It just Dl the page in .php i wanted to browse. –  Tristan Nov 10 '11 at 10:27

2 Answers 2

this was solved in a quick chat. seems that the problem appeared after APC php module was enabled. once APC was disabled the problem disappeared. It is unknown to me why APC was causing problems.

worth mentioning here for further references in similar scenarios... I guess.

share|improve this answer
    
I deleted my answer cause after reboot of the server, the problem re-appears. Even with APC disabled :/ so i'm stuck. –  Tristan Nov 10 '11 at 14:38
    
bah :( run a memtest maybe you have some faulty ram. if passed go for xdebug –  sysfault Nov 10 '11 at 14:55

Add to the .htaccess in the your webroot:

php_value memory_limit 512M
share|improve this answer
    
I have 2Go : memory_limit = 2048M; Why do i have to lower the value ? –  Tristan Nov 10 '11 at 9:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.