Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I just cloned the latest varnish git-repository to try and apply an enhancement (from git://github.com/varnish/Varnish-Cache.git)

All the dependencies listed on the website have been installed.

I run the following commands: ./autogen.sh -> works fine

./configure -> works fine too

make -> fails with the following error:

creating libvmod_std.la
(cd .libs && rm -f libvmod_std.la && ln -s ../libvmod_std.la libvmod_std.la)
========================================
You need rst2man installed to make dist
========================================
make[3]: *** [vmod_std.3] Error 1
make[3]: Leaving directory `/tmp/varnish-cache/lib/libvmod_std'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/varnish-cache/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/varnish-cache'
make: *** [all] Error 2

I have tried installing rst2man but it cannot be found since it's a virtual package?:

apt-get install rst2man
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package rst2man

Then I tried installing the python-docutils but that also did not solve the issue.

Any help would be appreciated!

Thanks in advance...

EDIT:

Commands I have ran after reading the answer:

I rebooted (first git clone is now gone since it was located in the /tmp directory)

cd /usr/share/
git clone git://github.com/varnish/Varnish-Cache.git
apt-get install python-docutils
./autogen.sh
./configure
make

=> Same error ;)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

After you installed python-docutils successfully make sure you clean the varnish sourcetree configuration cache and run configure again. make will then have what he needs (rst2man program, that is)

made a test. ran configure/make without rst2man, got the error. after installing python-docutils, I ran again configure which went fine, snip:

eu-we1:~/tmp/Varnish-Cache# ./configure |grep rst
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for rst2man... rst2man
checking for rst2html... rst2html
configure: WARNING: libedit not found, disabling libedit support
configure: WARNING: won't look for sendfile() on i686-pc-linux-gnu

make ran OK , exit code = 0 I guess you just need to make sure rst2man and probably rst2html as well (not sure) are found by configure script. I verified with a varnish git clone .

share|improve this answer
    
And how would I do that? I always do a "make clean" after it fails. Any other command I should run to clean the sourcetree configuration cache? –  KennyDs Nov 10 '11 at 9:51
    
remove any config.cache. if you use autogen to generate the configure script then run it again. the run ./configure. finally make should find rst2man. –  sysfault Nov 10 '11 at 9:53
    
usually make clean will remove any make generated files. if there's a make distclean target that should remove any configure generated files as well. if u remove config.cache, run again autogen,configure and make things should work ok, at least it will fix the current make error you encounter. –  sysfault Nov 10 '11 at 9:55
    
Just ran make clean , make distclean , autogen.sh , configure. While running make I bump across the same error as mentioned in the question. –  KennyDs Nov 10 '11 at 10:19
    
maybe you hit a but in the repo code. do ./configure --with-rst2man=/usr/bin/rst2man --with-rst2html=/usr/bin/rst2html or ./configure --without-rst2man --without-rst2html –  sysfault Nov 10 '11 at 10:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.