Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'd like to use "ipmitool ... sol activate" to record any kernel panics that may happen. I managed to keep GRUB2 in text-mode with "GRUB_TERMINAL=console" in /etc/default/grub. But right after the message "Loading initial ramdisk" (which is still GRUB), when Linux starts printing text on VGA console, messages on the serial console stop.

I guess either GRUB or Linux is doing something at that point, like loading a font, which kills off the vga-text-to-serial line. I'd like to keep it from doing that, whatever it is.

I have tried so far:

  • Kernel options "nofb nomodeset text" (the latter being for other Distros, I think).
  • GRUB_GFXPAYLOAD_LINUX=text

One obvious alternative is to setup serial console redirection to the virtual COM port, which should make panics appear on the serial-over-lan as well, but I'd prefer to stay in the initial text-mode, so VGA and console are in sync and both accept input.

share|improve this question
add comment

1 Answer

By default kernel does not output anything to serial ports. You should explictly mention it.
To solve this add following to GRUB_CMDLINE_LINUX_DEFAULT

console=tty0 console=ttyS0,9600n8

replace 9600n8 with your sol console settings.

share|improve this answer
    
This is the obvious alternative I mentioned and what I actually do right now. But what I want is stop the kernel from cutting off the vga-to-serial conversion (which would be the only way to accept input at both places, virtual-serial and physical-vga access). I think the BIOS stops vga-to-serial as soon as the virtual serial port gets activated by the OS in some way ... perhaps I need to blacklist serial? –  korkman Nov 18 '11 at 13:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.