Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting this error:

[Thu Nov 10 17:53:58 2011] [error] [client 95.240.108.197] File does not exist: /var/www/aib/web/aib

I don't know why it's looking for that file. I expected it looks for /var/www/aib/web/app.php.

This is my virtual-host configuration:

<VirtualHost 173.203.58.251:80>
  ServerName tirengarfio
  DocumentRoot "/var/www/aib/web"
  DirectoryIndex app.php

  ErrorLog "/var/log/apache2/aib.localhost-error.log"
  CustomLog "/var/log/apache2/aib.localhost-access.log" common
  TransferLog "/var/log/apache2/aib.localhost-transfer.log"

  <Directory "/var/www/aib/web">
    AllowOverride All
    Allow from All
  </Directory>

</VirtualHost>

Any idea?

Javi

share|improve this question
    
What address are you requesting in your browser? –  jdw Nov 10 '11 at 19:06
2  
Are there any .htaccess files in the document root? You have AllowOverride set to All, so perhaps there's some additional configuration that we aren't seeing. –  Nic Nov 10 '11 at 20:09
    
If you create a helloworld.txt file in the document root and access it through your browser, does it work? Or do you get a similar error message? Side note: how do you not have a TLD on your servername? Does apache accept that as correct syntax? I ask because I've never seen that before. –  Safado Nov 10 '11 at 20:23

1 Answer 1

up vote 1 down vote accepted

Without seeing the URL you are trying to load, it's a bit difficult to narrow down the cause.

I usually see these type of errors when Apache is trying to load a directory as if it's a file.

In your case, it looks like Apache thinks /var/www/aib/web/aib is a file, not a directory. This means the URL trying to be loaded is incorrect. Usually missing the trailing '/'.

To hit /var/www/aib/web/app.php you have to point your browser to http://tirengarfio/app.php

If you want apache to use app.php as the default index page you have to adjust your DirectoryIndex setting.

share|improve this answer
    
Thanks @David, I just was trying to access directly to the IP of my VPS (173.34.243.32). I turn on the computer today and there is no more that error.. –  user45761 Nov 11 '11 at 9:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.