Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have Dnsmasq configured on my network to give names to various IPv4 IP addresses on the network.

Pinging the other machines using their DNS names work fine when I have just IPv4 enabled on my client Windows 7 Ultimate 64-bit machine, but when I enable IPv6 support in the Win7 machine's list of protocols, I can no longer ping the machines using their DNS names.

enter image description here

I've even tried adding the -4 argument to the ping command, and also tried the -S command to specify the source ip to use when sending the ping.

Without IPv6 on the Windows 7 Machine enabled:

C:\Console2>ping asus.leerdomain.local

Pinging asus.leerdomain.local [192.168.1.149] with 32 bytes of data:
Reply from 192.168.1.149: bytes=32 time<1ms TTL=128
Reply from 192.168.1.149: bytes=32 time<1ms TTL=128

With IPv6 on the Windows 7 Machine enabled:

C:\utils\dig>ping asus.leerdomain.local Ping request could not
find host asus.leerdomain.local. Please check the name an d try again.

C:\utils\dig>ping -4  asus.leerdomain.local Ping request could not
find host asus.leerdomain.local. Please check the name an d try again.


C:\utils\dig>ping -4 -S192.168.1.149 asus.leerdomain.local
asus.leerdomain.local is not a valid address.

Both with and without IPv6 enabled on the Windows 7 Machine:

C:\utils\dig>dig asus.leerdomain.local

; <<>> DiG 9.3.2 <<>> asus.leerdomain.local
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1401
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;asus.leerdomain.local.         IN      A

;; ANSWER SECTION:
asus.leerdomain.local.  0       IN      A       192.168.1.149

;; Query time: 1 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Thu Nov 10 14:50:01 2011
;; MSG SIZE  rcvd: 55
share|improve this question

1 Answer 1

up vote 3 down vote accepted

Your machine is configured to respond to IPv4 pings and not to respond to IPv6 pings. When IPv6 is enabled, other machines gets the IPv6 address when they try to resolve the name because IPv6 is preferred. As a result, they issue a ping that does not get a reply.

ping -4 won't work because you can't do an IPv4 ping to an IPv6 address.

If you want the machine to respond to IPv6 pings, you'll have to figure out what's stopping it (a firewall, most likely) and fix the configuration.

share|improve this answer
    
great answer! By default win7 won't respond to pings so my bet would be the windows firewall. –  Jim B Nov 10 '11 at 20:50
    
@Dave Is that a bit like your router is configured not to respond to pings most of the time because of it's public ip? Because if the computer doesn't have a site local address (fec0-feff), than in IPv6 it's got a public ip? –  leeand00 Nov 10 '11 at 21:05
    
Also I imagine this would be because of the DENY-ALL default settings of IPv6 firewalls? –  leeand00 Nov 10 '11 at 21:10
    
Yeah you're right I was pining meself. –  leeand00 Nov 11 '11 at 5:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.