Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a SLES 10 SP1 domU on a SLES 11 SP1 dom0 for the purposes of a build server. After moving around some file systems, when I rebooted the domU, the networking no longer worked. When logging in via xm console, the only interface that was up was lo and the routing table was completely empty except for the route for lo. I have eth0 set to use dhcp, but when I run ifup eth0 I get the following error:

Nov 10 14:26:40 bitvm01 dhcpcd[6385]: timed out waiting for a valid DHCP server response

When trying rcnetwork restart, I get:

Warning: Could not set up default route via interface 
 Command ip route replace to default via 172.30.79.1 returned:
 . RTNETLINK answers: Network is unreachable
 Configuration line: default 172.30.79.1 - - 
 This needs NOT to be AN ERROR if you set up multiple interfaces.
 See man 5 routes how to avoid this warning.

If manually set the IP address:

ifconfig eth0 172.30.79.250 netmask 255.255.255.0
route add default gw 172.30.79.1

Then I can ping other hosts. I talked to the person* that originally set up the VM and he couldn't remember if he fixed it in a similar way before or not.

What am I missing? We have other SLES 10 SP1 (non-VM) servers that I used as a crib and that hasn't helped. I'm using a bridge for networking and it looks to be setup correctly on the dom0 with the correct vif in it.


Note: Said person is setting up another VM, same versions for the dom0 and domU, from scratch and is having the same problem. He has no issues with setting up a SLES 11 VM however.

share|improve this question
    
You know that SLES10 is currently at SP4 - don`t you? As far as I remember SLES10 was usable from SP2 on - and had some severe bugs before that. (just like SLES11 is usable from SP1 on) –  Nils Nov 10 '11 at 21:56
    
I knew it was greater than SP1. Can't change it though, stuck with SP1. –  sean Nov 10 '11 at 21:58
    
Support matrix problem? I usually ignore these for SPs. Anyway - have a look at the SP2-patches in the network-script area. I think this is where that specific bug was located. –  Nils Nov 10 '11 at 22:00
    
We ship(ped) systems based on just SP1. I'll check the network-script patches. –  sean Nov 10 '11 at 22:02

1 Answer 1

up vote 1 down vote accepted

There were two issues:

  • Most important was what Nils already mentioned: SLES 10 SP1 was kind of broken. I replaced the sysconfig package with one from SP3 and then networking finally would function properly. I believe /etc/sysconfig/network/scripts/ifup-route was the offending script, but I replaced them all to be safe.
  • The DHCP IP pool in the subnet was very small and so quickly exhausted. More IPs were added and everyone was happy.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.