Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Trying to install a fresh copy of Windows XP w/SP2 onto a system that was recently upgraded with a new motherboard (ASUS P5Q Pro), 8GB RAM, and a Core 2 Quad (why aren't these called 'Core 4s?).

The setup CD gets as far as 'Setup is inspecting your computer's hardware configuration', then the screen goes black and stays there. Not sure what the problem is, but I'm guessing something to do with 8 GB and/or the quad core.

Any ideas? I was expecting to have to provide some SATA drivers to it, but it doesn't get that far.

share|improve this question
    
Is it WinXP 32 or 64 bit? –  JFV Jun 28 '09 at 23:20
4  
It's not called a Core 4 because Core 2 does not relate to the number of cores, rather the 2nd generation of the "Core" processors (like Pentium/Pentium 2/3/4 did not represent the number of processors). –  Mark Henderson Jun 29 '09 at 0:03
    
What RAM combination do you have 2x4GB or 4x2GB ? –  JS. Jun 29 '09 at 18:30
    
4x2GB 1100Mhz DDR2 –  romandas Jun 30 '09 at 0:42
    
Try a Linux LiveCD and run memtest, see if your hardware is faulty. –  LiraNuna Jun 30 '09 at 1:17

7 Answers 7

up vote 2 down vote accepted

There are several reasons the system could hang at that point of startup. I will go over a few of the causes.

First off external devices. If you have anything connected via usb, esata, firewire remove them all during the install. See if your bios has an option to disable legacy usb devices.

Secondly is the hard drive itself. I assume its a SATA drive. Make sure it's connected to the first port on the motherboard usually SATA 0. Also make sure the drive is actually blank. If there are any old linux partitions on the drive that certainly could cause an issue.

Edit* I suppose that since you are installing a 32 bit os on a system with 8gb of ram might cause an issue, but i doubt it. XP 32 is only going to recognize about 3.5gb of that ram.

share|improve this answer
    
Your point about linux partitions seems to be what was causing the hang. Which leaves me in a conundrum about how to rescue the current install.. –  romandas Jun 30 '09 at 1:07
    
Accepted answer - the issue was the drive partitioning; blanking the partition table (even for a drive controller the setup disk did not have drivers for) allowed the partition table to boot. Since you mentioned this first, I accepted your answer. –  romandas Jul 1 '09 at 14:26
    
+1 for USB devices. Inadvertently connected USB sticks can make one run in circles during install. If you must use a stick to load drivers, connect it after the OS CD starts up. –  dmoisan Aug 26 '09 at 13:35
    
Appreciate it. Glad you got it. –  user10711 Aug 26 '09 at 16:28
  1. Make sure your motherboard isn't set to raid mode.
  2. If you have SATA drivers or RAID drivers make sure you load them with F6 at the beginning of the install.
  3. Make sure you unplug or disable any unnecessary hardware.
  4. If you have alternatives, try the onboard VGA and not the PCIx display card.
  5. Try taking out 4-6GB of Ram, to see if you can get past it. The 32 Bit XP can only address 4 GB of RAM anyways (before memory addressing for video, BIOS, and other devices).
share|improve this answer

Grab a copy of Memtest86+ (http://www.memtest.org/) and run that for at least one full cycle. There's a chance you've got some iffy RAM.

Edit:

Out of curiosity, what happens if you boot the CD with the all the hard disk drive(s) in the machine disconnected? Obviously, it won't install this way. I'm just curious if it hangs the same way. I'm seeing some posts on other sites from people who found that an existing installation on the hard disk drive was causing this type of hang that you're seeing.

Edit 2:

Ahh! My psychic powers pay off. What's on those drives now? You might try plugging-in only the drive you want to install onto. I would bet that if you plug in a completely empty disk (zeroed-out with a "disk nuke" utility or some such) that it'll boot the CD fine. My guess is that you're tickling a bug here.

The debug-checked version of NTDETECT.COM could tell you what's going on, but getting that onto the Windows XP CD in a bootable fashion is going to be a lot of work. I'd see if you can muddle thru the install w/ a wiped disk, as I've suggested, and then see how she boots when you plug all the disks back in.

share|improve this answer
    
I did -- let it run overnight actually, and it was clean. No memory troubles. –  romandas Jun 29 '09 at 12:11
    
I just dropped in an edit. If you have time, see what that does. –  Evan Anderson Jun 29 '09 at 14:26
    
+1 Nice suggestion - The CD boots without the drives in. Which, I don't understand why it would matter, considering they're SATA drives and I believe the CD needs a driver to see them in the first place. Weird. –  romandas Jun 30 '09 at 0:48
    
I dropped another edit on here. We're zeroing in on the issue, I think. –  Evan Anderson Jun 30 '09 at 0:59
    
I wiped the partition table using dd if=/dev/zero of=/dev/sda bs=512 count=1 and the CD boots. So, apparently it's something with the lilo/linux-based partition creation. What stumps me now is how to rescue the previous install instead of rebuilding from scratch. (I do have a backup; didn't wipe the partition table on the only drive :)) –  romandas Jun 30 '09 at 1:05

I haven't had any issues installing WinXP (SP2 or otherwise) where it asks for SATA Drivers (and I have the P5Q Pro MB). I've always been able to boot and start up without any issues. If you think that there might be a hardware issue, try pulling 2 of the 4 sticks of RAM and see if it continues. I've seen that cause issues on other systems...

share|improve this answer

Check the CD Drive, I've had installs lockup/crash because the CD Drive was flaky.

share|improve this answer

Make sure that hardware installed properly. Try to reassemble hardware components.

share|improve this answer

Slipstream (using nlite) both SP3 and the SATA drivers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.