Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server that takes several minutes for the NIC to bind itself to the network upon startup (it has a statically-configured IP). This causes the WINS and Intersite Messaging services (and sometimes DNS) to fail to start, since they're dependent on a network connection, and they must be started manually. I've done firmware updates and checked for any odd drivers/services, but no luck so far. The server is running Server 2008 R2 SP1 and only has one NIC installed.

(On a side note, there are two other small but odd problems occuring with the server. The server had the issue described in KB2298620, which I've fixed. The other problem occurs in Windows Server Backup. No events appear in the upper portion of the window, despite the fact that backups are running in the background. Whenever I attempt to modify the backup schedule, it gives me the error "Not enough storage is available to process this command" and appears to fail, when, in fact, it actually succeeds. These may be separate issues, but something tells me that some of these might share a common root cause.)

share|improve this question
add comment

2 Answers

Do you have multiple NICs in the machine? Are any NICs that are not physically connected disabled through Windows? If the NIC is active but unplugged it can cause delays in the network stack becoming available for the OS.

What version of the OS are you using?

share|improve this answer
    
Only one NIC, running on Server 2008 R2, fully patched. –  Bigbio2002 Nov 11 '11 at 17:49
add comment

If your switchport is STP(spanning tree) enabled and not in "portfast", then it takes about 30 secs before the switch allows it to connect. Check your swirch configuration

share|improve this answer
    
The switch has RSTP enabled. Isn't that supposed to be faster? –  Bigbio2002 Mar 8 '12 at 22:24
    
RSTP is good when a link is down and STP can put the traffic faster on the other link. Also it also works well only if all switches on the network are RSTP enabled. Try portfast and use bpduguard setting, as with portfast you may make a loop later but bpduguard eill prevenr it –  Gabor Vincze Mar 8 '12 at 22:52
    
portfast? bpduguard? These terms are unfamiliar. –  Bigbio2002 Mar 8 '12 at 22:57
    
What is the brand and type of your switch ? –  Gabor Vincze Mar 8 '12 at 23:08
    
It's a Netgear GS748TP. –  Bigbio2002 Mar 11 '12 at 2:12
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.